summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-02-13 04:05:57 +0000
committerTim Harder <radhermit@gentoo.org>2012-02-13 04:05:57 +0000
commit946c5c409bc2dbe5499714d5484621beae072182 (patch)
treeba8b077862cb5cc3f118be2dc083e2aafbfb09a9 /dev-python/pygit2
parentVersion bump. (diff)
downloadgentoo-2-946c5c409bc2dbe5499714d5484621beae072182.tar.gz
gentoo-2-946c5c409bc2dbe5499714d5484621beae072182.tar.bz2
gentoo-2-946c5c409bc2dbe5499714d5484621beae072182.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/ChangeLog9
-rw-r--r--dev-python/pygit2/pygit2-0.16.0.ebuild29
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-python/pygit2/ChangeLog b/dev-python/pygit2/ChangeLog
index be188a0b4ccb..32f871acc3e5 100644
--- a/dev-python/pygit2/ChangeLog
+++ b/dev-python/pygit2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pygit2
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/ChangeLog,v 1.3 2011/12/15 21:34:47 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/ChangeLog,v 1.4 2012/02/13 04:05:57 radhermit Exp $
+
+*pygit2-0.16.0 (13 Feb 2012)
+
+ 13 Feb 2012; Tim Harder <radhermit@gentoo.org> +pygit2-0.16.0.ebuild:
+ Version bump.
*pygit2-0.15.1 (15 Dec 2011)
diff --git a/dev-python/pygit2/pygit2-0.16.0.ebuild b/dev-python/pygit2/pygit2-0.16.0.ebuild
new file mode 100644
index 000000000000..674e29576ef0
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.16.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/pygit2-0.16.0.ebuild,v 1.1 2012/02/13 04:05:57 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.6 3:3.1"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2"
+SRC_URI="https://github.com/libgit2/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="~dev-libs/libgit2-${PV}
+ dev-libs/openssl
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}