summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-03-28 22:16:32 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-03-28 22:16:32 +0000
commit69ca4bf9ba3fb5ccab244b1ad2f71bebbd306869 (patch)
treede567705dc760ea69cb5fbe21b04652652fa323c /dev-python/pygtk
parentLinux patch 2.6.32.36 (diff)
downloadgentoo-2-69ca4bf9ba3fb5ccab244b1ad2f71bebbd306869.tar.gz
gentoo-2-69ca4bf9ba3fb5ccab244b1ad2f71bebbd306869.tar.bz2
gentoo-2-69ca4bf9ba3fb5ccab244b1ad2f71bebbd306869.zip
Version bump. Add gtk-2.24 support, document updates.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pygtk')
-rw-r--r--dev-python/pygtk/ChangeLog8
-rw-r--r--dev-python/pygtk/pygtk-2.17.0.ebuild95
-rw-r--r--dev-python/pygtk/pygtk-2.23.2.ebuild (renamed from dev-python/pygtk/pygtk-2.22.0.ebuild)16
3 files changed, 14 insertions, 105 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index b17cdac02687..e159728a3ec1 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygtk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.253 2011/03/22 19:03:56 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.254 2011/03/28 22:16:32 eva Exp $
+
+*pygtk-2.23.2 (28 Mar 2011)
+
+ 28 Mar 2011; Gilles Dartiguelongue <eva@gentoo.org> -pygtk-2.17.0.ebuild,
+ -pygtk-2.22.0.ebuild, +pygtk-2.23.2.ebuild:
+ Version bump. Add gtk-2.24 support, document updates.
22 Mar 2011; Brent Baude <ranger@gentoo.org> pygtk-2.22.0-r1.ebuild:
Marking pygtk-2.22.0-r1 ppc stable for bug 353436
diff --git a/dev-python/pygtk/pygtk-2.17.0.ebuild b/dev-python/pygtk/pygtk-2.17.0.ebuild
deleted file mode 100644
index a0c718aef5f4..000000000000
--- a/dev-python/pygtk/pygtk-2.17.0.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.17.0.ebuild,v 1.12 2011/03/16 10:14:30 nirbheek Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-
-inherit alternatives autotools eutils flag-o-matic gnome.org python virtualx
-
-DESCRIPTION="GTK+2 bindings for Python"
-HOMEPAGE="http://www.pygtk.org/"
-
-LICENSE="LGPL-2.1"
-SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples"
-
-RDEPEND=">=dev-libs/glib-2.8:2
- >=x11-libs/pango-1.16
- >=dev-libs/atk-1.12
- >=x11-libs/gtk+-2.18:2
- >=gnome-base/libglade-2.5:2.0
- >=dev-python/pycairo-1.0.2
- >=dev-python/pygobject-2.16.1:2
- dev-python/numpy"
-
-DEPEND="${RDEPEND}
- doc? (
- dev-libs/libxslt
- >=app-text/docbook-xsl-stylesheets-1.70.1 )
- >=dev-util/pkgconfig-0.9"
-
-src_prepare() {
- # Fix declaration of codegen in .pc
- epatch "${FILESDIR}/${PN}-2.13.0-fix-codegen-location.patch"
-
- # Disable pyc compiling
- mv "${S}"/py-compile "${S}"/py-compile.orig
- ln -s $(type -P true) "${S}"/py-compile
-
- AT_M4DIR="m4" eautoreconf
-
- python_copy_sources
-}
-
-src_configure() {
- use hppa && append-flags -ffunction-sections
- python_src_configure $(use_enable doc docs) --enable-thread
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
-
- testing() {
- cd tests
- export XDG_CONFIG_HOME="${T}/$(PYTHON --ABI)"
- Xemake check-local
- }
- python_execute_function -s testing
-}
-
-src_install() {
- python_src_install
- python_clean_installation_image
- dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO
-
- if use examples; then
- rm examples/Makefile*
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize gtk-2.0
-
- create_symlinks() {
- alternatives_auto_makesym $(python_get_sitedir)/pygtk.py pygtk.py-[0-9].[0-9]
- alternatives_auto_makesym $(python_get_sitedir)/pygtk.pth pygtk.pth-[0-9].[0-9]
- }
- python_execute_function create_symlinks
-}
-
-pkg_postrm() {
- python_mod_cleanup gtk-2.0
-
- create_symlinks() {
- alternatives_auto_makesym $(python_get_sitedir)/pygtk.py pygtk.py-[0-9].[0-9]
- alternatives_auto_makesym $(python_get_sitedir)/pygtk.pth pygtk.pth-[0-9].[0-9]
- }
- python_execute_function create_symlinks
-}
diff --git a/dev-python/pygtk/pygtk-2.22.0.ebuild b/dev-python/pygtk/pygtk-2.23.2.ebuild
index 846881a97ab1..132f20889da4 100644
--- a/dev-python/pygtk/pygtk-2.22.0.ebuild
+++ b/dev-python/pygtk/pygtk-2.23.2.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.22.0.ebuild,v 1.3 2011/03/16 10:14:30 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.23.2.ebuild,v 1.1 2011/03/28 22:16:32 eva Exp $
EAPI="3"
GCONF_DEBUG="no"
-PYTHON_DEPEND="2:2.5"
+PYTHON_DEPEND="2:2.6"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+# dev-python/pycairo does not support Python 2.4 / 2.5.
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
inherit alternatives autotools eutils flag-o-matic gnome.org python virtualx
@@ -22,12 +23,12 @@ IUSE="doc examples"
RDEPEND=">=dev-libs/glib-2.8:2
>=x11-libs/pango-1.16
>=dev-libs/atk-1.12
- >=x11-libs/gtk+-2.22:2
+ >=x11-libs/gtk+-2.24:2
>=gnome-base/libglade-2.5:2.0
>=dev-python/pycairo-1.0.2
>=dev-python/pygobject-2.21.3:2
- dev-python/numpy"
-
+ dev-python/numpy
+"
DEPEND="${RDEPEND}
doc? (
dev-libs/libxslt
@@ -38,9 +39,6 @@ src_prepare() {
# Fix declaration of codegen in .pc
epatch "${FILESDIR}/${PN}-2.13.0-fix-codegen-location.patch"
- # Broken test, upstream bug #636589
- epatch "${FILESDIR}/${PN}-2.22.0-disable-broken-tests.patch"
-
# Disable pyc compiling
mv "${S}"/py-compile "${S}"/py-compile.orig
ln -s $(type -P true) "${S}"/py-compile