summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-15 12:59:16 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-15 12:59:16 +0000
commit6997c2f3d72f867d41f4e28afe0a951d7b6ef42f (patch)
tree4c62bdeeae43201912e962dc4dabe01ab92034ed /dev-python/pyh2o
parentImport the live ebuild. (diff)
downloadgentoo-2-6997c2f3d72f867d41f4e28afe0a951d7b6ef42f.tar.gz
gentoo-2-6997c2f3d72f867d41f4e28afe0a951d7b6ef42f.tar.bz2
gentoo-2-6997c2f3d72f867d41f4e28afe0a951d7b6ef42f.zip
Import the live ebuild for pyh2o, Python bindings for libh2o.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/pyh2o')
-rw-r--r--dev-python/pyh2o/ChangeLog9
-rw-r--r--dev-python/pyh2o/Manifest3
-rw-r--r--dev-python/pyh2o/metadata.xml15
-rw-r--r--dev-python/pyh2o/pyh2o-9999.ebuild29
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pyh2o/ChangeLog b/dev-python/pyh2o/ChangeLog
new file mode 100644
index 000000000000..8192cd082c00
--- /dev/null
+++ b/dev-python/pyh2o/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/pyh2o
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyh2o/ChangeLog,v 1.1 2012/12/15 12:59:16 mgorny Exp $
+
+*pyh2o-9999 (15 Dec 2012)
+
+ 15 Dec 2012; Michał Górny <mgorny@gentoo.org> +metadata.xml,
+ +pyh2o-9999.ebuild:
+ Import the live ebuild for pyh2o, Python bindings for libh2o.
diff --git a/dev-python/pyh2o/Manifest b/dev-python/pyh2o/Manifest
new file mode 100644
index 000000000000..f87d28997bda
--- /dev/null
+++ b/dev-python/pyh2o/Manifest
@@ -0,0 +1,3 @@
+EBUILD pyh2o-9999.ebuild 594 SHA256 c1c1f990e8667a33af1e4a0951f8a81bbddabc8ae4bb866f436b156a08f0b027 SHA512 2dead6aa1e1f0d1a49c536897b202b571cdfdaf3a33495b5ea88e8f837e71a1acd594a35878200402e821a005fe91bd1ae43cb6c9af3c97eda9b757be04afb11 WHIRLPOOL 5b5cbd9ba9aa34918d4f61a2e17b01ae996f4a008beec8f284417d59a15829235ea4cf748a0ac01b557e98b41036e9883250ae94a5cfcd0488e710368affbda0
+MISC ChangeLog 295 SHA256 20048af82cc39e7600ba7aa55a317f39820c429507d61d29391cef9d32803dd8 SHA512 7351faed095381d01af42c52d41d721ae142cfc1241aedf1eb52fa5b87b1b142f599ecd1cc1f504346019b10391b54a4cda4dd34ce0d54756ff3816e0342e191 WHIRLPOOL 9bad0b151e702c3f66e5989454cec34d7046521175dfb707ddeb06bdad8eb2a8ff14a9a278c731f04e131158272bf501364e5bd8b8f3696d0cee1e4751bb5571
+MISC metadata.xml 436 SHA256 a09655b3f25fb0354b1d20b27c6f620f8330847defbf75702045787d80287575 SHA512 d3be54e204c6a9b46f737a8a93c8c59ffffe0f5b3f13520b28fe46aa9ac61018b94d71ef526436e3ff98e4e5a23e05b75b3b32e27014f1971e358be49de22d52 WHIRLPOOL 4f7569418fefa51b885ab20ed900cd25439c72c464fb43226793284ace07b30e4c50218cf419f7244348dfb2aa8667ebda783e2452e3f7e51536c45463483767
diff --git a/dev-python/pyh2o/metadata.xml b/dev-python/pyh2o/metadata.xml
new file mode 100644
index 000000000000..07308e92faf9
--- /dev/null
+++ b/dev-python/pyh2o/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://bitbucket.org/mgorny/pyh2o/issues/</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyh2o/pyh2o-9999.ebuild b/dev-python/pyh2o/pyh2o-9999.ebuild
new file mode 100644
index 000000000000..d6952265475b
--- /dev/null
+++ b/dev-python/pyh2o/pyh2o-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyh2o/pyh2o-9999.ebuild,v 1.1 2012/12/15 12:59:16 mgorny Exp $
+
+EAPI=4
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9} )
+
+inherit distutils-r1
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-2
+#endif
+
+DESCRIPTION="Library of routines for IF97 water & steam properties"
+HOMEPAGE="https://bitbucket.org/mgorny/libh2o/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif