summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-10-01 01:12:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-10-01 01:12:55 +0000
commit986da312382879adc5c52cfbcb852da3be46be35 (patch)
treeee8368df677f74e2af9d565e068467f68320d8f9 /dev-python/pyml
parentVersion bump. Cleanup old. (diff)
downloadgentoo-2-986da312382879adc5c52cfbcb852da3be46be35.tar.gz
gentoo-2-986da312382879adc5c52cfbcb852da3be46be35.tar.bz2
gentoo-2-986da312382879adc5c52cfbcb852da3be46be35.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pyml')
-rw-r--r--dev-python/pyml/ChangeLog7
-rw-r--r--dev-python/pyml/pyml-0.7.13.2.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/pyml/ChangeLog b/dev-python/pyml/ChangeLog
index 49204749f84f..0463fa46714f 100644
--- a/dev-python/pyml/ChangeLog
+++ b/dev-python/pyml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyml
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyml/ChangeLog,v 1.4 2013/09/18 06:27:45 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyml/ChangeLog,v 1.5 2013/10/01 01:12:55 patrick Exp $
+
+*pyml-0.7.13.2 (01 Oct 2013)
+
+ 01 Oct 2013; Patrick Lauer <patrick@gentoo.org> +pyml-0.7.13.2.ebuild:
+ Bump
*pyml-0.7.13.1 (18 Sep 2013)
diff --git a/dev-python/pyml/pyml-0.7.13.2.ebuild b/dev-python/pyml/pyml-0.7.13.2.ebuild
new file mode 100644
index 000000000000..a8ca15879b59
--- /dev/null
+++ b/dev-python/pyml/pyml-0.7.13.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyml/pyml-0.7.13.2.ebuild,v 1.1 2013/10/01 01:12:55 patrick Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-pypy-* *-jython"
+
+inherit distutils
+
+MYP=PyML-${PV}
+
+DESCRIPTION="Python machine learning package"
+HOMEPAGE="http://pyml.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="dev-python/numpy"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MYP}"
+
+src_test() {
+ cd data
+ testing() {
+ PYTHONPATH="$(ls -d ${S}/build-${PYTHON_ABI}/lib*)" \
+ "$(PYTHON)" -c "from PyML.demo import pyml_test; pyml_test.test('svm')" || return 1
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dodoc doc/tutorial.pdf && dohtml -r doc/autodoc/*
+}