summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2013-06-02 16:21:35 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2013-06-02 16:21:35 +0000
commit3ec93f025718974afc3189010cc5cea647b413b4 (patch)
treec843f4acdcc800cf4c954354d9b4d5f8516136bd /dev-python/pymongo
parentRun user.eclass functions conditionally, and in pkg_preinst too. Fix CFLAGS -... (diff)
downloadgentoo-2-3ec93f025718974afc3189010cc5cea647b413b4.tar.gz
gentoo-2-3ec93f025718974afc3189010cc5cea647b413b4.tar.bz2
gentoo-2-3ec93f025718974afc3189010cc5cea647b413b4.zip
fix #472046 wrt #472034, drop old
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'dev-python/pymongo')
-rw-r--r--dev-python/pymongo/ChangeLog8
-rw-r--r--dev-python/pymongo/pymongo-2.3.ebuild59
-rw-r--r--dev-python/pymongo/pymongo-2.5.2.ebuild (renamed from dev-python/pymongo/pymongo-2.5.1.ebuild)4
-rw-r--r--dev-python/pymongo/pymongo-2.5.ebuild129
4 files changed, 9 insertions, 191 deletions
diff --git a/dev-python/pymongo/ChangeLog b/dev-python/pymongo/ChangeLog
index f6689bf28327..d5d0180e477d 100644
--- a/dev-python/pymongo/ChangeLog
+++ b/dev-python/pymongo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pymongo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/ChangeLog,v 1.26 2013/05/28 18:24:32 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/ChangeLog,v 1.27 2013/06/02 16:21:35 ultrabug Exp $
+
+*pymongo-2.5.2 (02 Jun 2013)
+
+ 02 Jun 2013; Ultrabug <ultrabug@gentoo.org> -pymongo-2.3.ebuild,
+ -pymongo-2.5.ebuild, -pymongo-2.5.1.ebuild, +pymongo-2.5.2.ebuild:
+ fix #472046 wrt #472034, drop old
28 May 2013; Ian Delaney <idella4@gentoo.org>
+files/pymongo-2.5.1-greenlet.patch, pymongo-2.5.1.ebuild, pymongo-2.5.ebuild:
diff --git a/dev-python/pymongo/pymongo-2.3.ebuild b/dev-python/pymongo/pymongo-2.3.ebuild
deleted file mode 100644
index 87cfc756f8ae..000000000000
--- a/dev-python/pymongo/pymongo-2.3.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/pymongo-2.3.ebuild,v 1.2 2012/11/12 14:59:02 idella4 Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*-jython"
-DISTUTILS_SRC_TEST="nosetests"
-PYTHON_TESTS_RESTRICTED_ABIS="3.*"
-inherit distutils
-
-DESCRIPTION="Python driver for MongoDB"
-HOMEPAGE="http://github.com/mongodb/mongo-python-driver http://pypi.python.org/pypi/pymongo"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc mod_wsgi"
-
-RDEPEND="dev-db/mongodb"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-PYTHON_MODNAME="bson gridfs pymongo"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- mkdir html
- sphinx-build doc html || die "Generation of documentation failed"
- fi
-}
-
-distutils_src_test_pre_hook() {
- mkdir -p "${T}/tests-${PYTHON_ABI}/mongo.db"
- mongod --dbpath "${T}/tests-${PYTHON_ABI}/mongo.db" --fork --logpath "${T}/tests-${PYTHON_ABI}/mongo.log"
-}
-
-src_test() {
- distutils_src_test
- killall -u "$(id -nu)" mongod
-}
-
-src_install() {
- # Maintainer note:
- # In order to work with mod_wsgi, we need to disable the C extension.
- # See [1] for more information.
- # [1] http://api.mongodb.org/python/current/faq.html#does-pymongo-work-with-mod-wsgi
- distutils_src_install $(use mod_wsgi && echo --no_ext)
-
- if use doc; then
- dohtml -r html/* || die "Error installing docs"
- fi
-}
diff --git a/dev-python/pymongo/pymongo-2.5.1.ebuild b/dev-python/pymongo/pymongo-2.5.2.ebuild
index 70c9c0612011..b22cdc1e1886 100644
--- a/dev-python/pymongo/pymongo-2.5.1.ebuild
+++ b/dev-python/pymongo/pymongo-2.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/pymongo-2.5.1.ebuild,v 1.6 2013/05/28 18:24:32 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/pymongo-2.5.2.ebuild,v 1.1 2013/06/02 16:21:35 ultrabug Exp $
EAPI=5
@@ -42,7 +42,7 @@ pkg_setup() {
reqcheck pkg_setup
}
-PATCHES=( "${FILESDIR}"/${P}-greenlet.patch )
+PATCHES=( "${FILESDIR}"/${PN}-2.5.1-greenlet.patch )
python_compile_all() {
if use doc; then
diff --git a/dev-python/pymongo/pymongo-2.5.ebuild b/dev-python/pymongo/pymongo-2.5.ebuild
deleted file mode 100644
index dabce41b7add..000000000000
--- a/dev-python/pymongo/pymongo-2.5.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/pymongo-2.5.ebuild,v 1.1 2013/03/25 09:20:07 ultrabug Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
-
-inherit check-reqs distutils-r1
-
-DESCRIPTION="Python driver for MongoDB"
-HOMEPAGE="http://github.com/mongodb/mongo-python-driver http://pypi.python.org/pypi/pymongo"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc kerberos mod_wsgi test"
-
-RDEPEND="dev-db/mongodb"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- kerberos? ( dev-python/pykerberos )"
-
-reqcheck() {
- if use test; then
- # During the tests, database size reaches 1.5G.
- local CHECKREQS_DISK_BUILD=1536M
-
- check-reqs_${1}
- fi
-}
-
-pkg_pretend() {
- reqcheck pkg_pretend
-}
-
-pkg_setup() {
- reqcheck pkg_setup
-}
-
-python_compile_all() {
- if use doc; then
- mkdir html || die
- sphinx-build doc html || die
- fi
-}
-
-src_test() {
- # Yes, we need TCP/IP for that...
- local DB_IP=127.0.0.1
- local DB_PORT=27017
-
- export DB_IP DB_PORT
-
- # 1.5G of disk space per run.
- local DISTUTILS_NO_PARALLEL_BUILD=1
-
- distutils-r1_src_test
-}
-
-python_test() {
- local dbpath=${TMPDIR}/mongo.db
- local logpath=${TMPDIR}/mongod.log
-
- # Now, the hard part: we need to find a free port for mongod.
- # We're just trying to run it random port numbers and check the log
- # for bind errors. It shall be noted that 'mongod --fork' does not
- # return failure when it fails to bind.
-
- mkdir -p "${dbpath}" || die
- while true; do
- ebegin "Trying to start mongod on port ${DB_PORT}"
-
- LC_ALL=C \
- mongod --dbpath "${dbpath}" --smallfiles --nojournal \
- --bind_ip ${DB_IP} --port ${DB_PORT} \
- --unixSocketPrefix "${TMPDIR}" \
- --logpath "${logpath}" --fork \
- && sleep 2
-
- # Now we need to check if the server actually started...
- if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
- # yay!
- eend 0
- break
- elif grep -q 'Address already in use' "${logpath}"; then
- # ay, someone took our port!
- eend 1
- : $(( DB_PORT += 1 ))
- continue
- else
- eend 1
- eerror "Unable to start mongod for tests. See the server log:"
- eerror " ${logpath}"
- die "Unable to start mongod for tests."
- fi
- done
-
- local failed
- nosetests || failed=1
-
- mongod --dbpath "${dbpath}" --shutdown
-
- [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
-
- rm -rf "${dbpath}"
-}
-
-python_install() {
- # Maintainer note:
- # In order to work with mod_wsgi, we need to disable the C extension.
- # See [1] for more information.
- # [1] http://api.mongodb.org/python/current/faq.html#does-pymongo-work-with-mod-wsgi
- distutils-r1_python_install $(use mod_wsgi && echo --no_ext)
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( html/. )
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- ewarn "Important changes on this release, make sure to read the changelog:"
- ewarn "http://api.mongodb.org/python/${PV}/changelog.html"
-}