summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-03 08:55:51 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-03 08:55:51 +0000
commit0a9f071cfe1621b489f4db7dfd575d24eccf9cc1 (patch)
tree8c0d9bc1c978ed760bd41861ce9df721c7e03542 /dev-python/pyopencl
parentx86 stable wrt bug #500914 (diff)
downloadgentoo-2-0a9f071cfe1621b489f4db7dfd575d24eccf9cc1.tar.gz
gentoo-2-0a9f071cfe1621b489f4db7dfd575d24eccf9cc1.tar.bz2
gentoo-2-0a9f071cfe1621b489f4db7dfd575d24eccf9cc1.zip
revbump; convert -> distutils-r1, add py3 support
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/ChangeLog9
-rw-r--r--dev-python/pyopencl/pyopencl-2013.2-r1.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-python/pyopencl/ChangeLog b/dev-python/pyopencl/ChangeLog
index b7469b6ddd1d..17ed09441f08 100644
--- a/dev-python/pyopencl/ChangeLog
+++ b/dev-python/pyopencl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyopencl
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/ChangeLog,v 1.22 2013/11/07 06:45:05 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/ChangeLog,v 1.23 2014/04/03 08:55:51 idella4 Exp $
+
+*pyopencl-2013.2-r1 (03 Apr 2014)
+
+ 03 Apr 2014; Ian Delaney <idella4@gentoo.org> +pyopencl-2013.2-r1.ebuild:
+ revbump; convert -> distutils-r1, add py3 support
*pyopencl-2013.2 (07 Nov 2013)
diff --git a/dev-python/pyopencl/pyopencl-2013.2-r1.ebuild b/dev-python/pyopencl/pyopencl-2013.2-r1.ebuild
new file mode 100644
index 000000000000..1de7e4e55c11
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2013.2-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-2013.2-r1.ebuild,v 1.1 2014/04/03 08:55:51 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="http://mathema.tician.de/software/pyopencl http://pypi.python.org/pypi/pyopencl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl"
+
+RDEPEND=">=dev-libs/boost-1.48[python]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/pytools[${PYTHON_USEDEP}]
+ >=virtual/opencl-0-r1"
+DEPEND="${RDEPEND}"
+
+src_configure()
+{
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${PYTHON}" configure.py \
+ --boost-compiler=gcc \
+ --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
+ --no-use-shipped-boost \
+ "${myconf[@]}"
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ if use examples; then
+ local EXAMPLES=( examples/. )
+ einfo "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+ distutils-r1_python_install_all
+}