summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-05-21 15:32:38 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-05-21 15:32:38 +0000
commitacd8ae4bd368b6f8c143719a431cd421ea4e9fe5 (patch)
tree0cc1ad2b799d5952095df446308711342b1f9992 /dev-python/pypax/pypax-0.8.3.ebuild
parentStable for HPPA (bug #470344). (diff)
downloadgentoo-2-acd8ae4bd368b6f8c143719a431cd421ea4e9fe5.tar.gz
gentoo-2-acd8ae4bd368b6f8c143719a431cd421ea4e9fe5.tar.bz2
gentoo-2-acd8ae4bd368b6f8c143719a431cd421ea4e9fe5.zip
Version bump: rename pax-mark to avoid name collision
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-python/pypax/pypax-0.8.3.ebuild')
-rw-r--r--dev-python/pypax/pypax-0.8.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pypax/pypax-0.8.3.ebuild b/dev-python/pypax/pypax-0.8.3.ebuild
new file mode 100644
index 000000000000..09c34b6c7c64
--- /dev/null
+++ b/dev-python/pypax/pypax-0.8.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypax/pypax-0.8.3.ebuild,v 1.1 2013/05/21 15:32:38 blueness Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to get or set either PT_PAX and/or XATTR_PAX flags"
+HOMEPAGE="http://dev.gentoo.org/~blueness/elfix/
+ http://www.gentoo.org/proj/en/hardened/pax-quickstart.xml"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/elfix-${PV}.tar.gz"
+
+S="${WORKDIR}/elfix-${PV}/scripts"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+ptpax +xtpax"
+
+REQUIRED_USE="|| ( ptpax xtpax )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ptpax? ( dev-libs/elfutils )
+ xtpax? ( sys-apps/attr )"
+
+RDEPEND=""
+
+src_compile() {
+ unset PTPAX
+ unset XTPAX
+ use ptpax && export PTPAX="yes"
+ use xtpax && export XTPAX="yes"
+}