summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-05-20 22:05:36 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-05-20 22:05:36 +0000
commitb6afa2b0740958719d57888d4f5362083c25cc94 (patch)
treefd33b49f7c18186f676262c77a62028ff79baed3 /dev-python/pypax
parentimport changes made by graff which I missed on the bump (diff)
downloadgentoo-2-b6afa2b0740958719d57888d4f5362083c25cc94.tar.gz
gentoo-2-b6afa2b0740958719d57888d4f5362083c25cc94.tar.bz2
gentoo-2-b6afa2b0740958719d57888d4f5362083c25cc94.zip
Version bump: avoid ELF_C_RDWR_MMAP for uclibc systems
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-python/pypax')
-rw-r--r--dev-python/pypax/ChangeLog7
-rw-r--r--dev-python/pypax/pypax-0.8.2.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/pypax/ChangeLog b/dev-python/pypax/ChangeLog
index 350306e09e04..e40a3b28a21d 100644
--- a/dev-python/pypax/ChangeLog
+++ b/dev-python/pypax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pypax
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pypax/ChangeLog,v 1.60 2013/04/13 07:36:48 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypax/ChangeLog,v 1.61 2013/05/20 22:05:36 blueness Exp $
+
+*pypax-0.8.2 (20 May 2013)
+
+ 20 May 2013; Anthony G. Basile <blueness@gentoo.org> +pypax-0.8.2.ebuild:
+ Version bump: avoid ELF_C_RDWR_MMAP for uclibc systems
13 Apr 2013; Agostino Sarubbo <ago@gentoo.org> pypax-0.8.1-r1.ebuild:
Stable for sparc, wrt bug #464426
diff --git a/dev-python/pypax/pypax-0.8.2.ebuild b/dev-python/pypax/pypax-0.8.2.ebuild
new file mode 100644
index 000000000000..90daf4637a03
--- /dev/null
+++ b/dev-python/pypax/pypax-0.8.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypax/pypax-0.8.2.ebuild,v 1.1 2013/05/20 22:05:36 blueness Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to get or set either PT_PAX and/or XATTR_PAX flags"
+HOMEPAGE="http://dev.gentoo.org/~blueness/elfix/
+ http://www.gentoo.org/proj/en/hardened/pax-quickstart.xml"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/elfix-${PV}.tar.gz"
+
+S="${WORKDIR}/elfix-${PV}/scripts"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+ptpax +xtpax"
+
+REQUIRED_USE="|| ( ptpax xtpax )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ptpax? ( dev-libs/elfutils )
+ xtpax? ( sys-apps/attr )"
+
+RDEPEND=""
+
+src_compile() {
+ unset PTPAX
+ unset XTPAX
+ use ptpax && export PTPAX="yes"
+ use xtpax && export XTPAX="yes"
+}