summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-18 14:24:14 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-18 14:24:14 +0000
commitd31165235b92f5769bb757201276f6c003dd5331 (patch)
tree5099f741f5e0eb38aa1ab0e9d23ebac86feb21c8 /dev-python/pypcap/files
parentarm/m68k/s390/sh stable wrt #265376 (diff)
downloadgentoo-2-d31165235b92f5769bb757201276f6c003dd5331.tar.gz
gentoo-2-d31165235b92f5769bb757201276f6c003dd5331.tar.bz2
gentoo-2-d31165235b92f5769bb757201276f6c003dd5331.zip
Small patch to fix compilation issues, thanks to Mike Kazantsev. Closes #247145
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pypcap/files')
-rw-r--r--dev-python/pypcap/files/include_path.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-python/pypcap/files/include_path.patch b/dev-python/pypcap/files/include_path.patch
new file mode 100644
index 000000000000..a02c82e208c1
--- /dev/null
+++ b/dev-python/pypcap/files/include_path.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index 9aada5a..71d0d34 100644
+--- a/setup.py
++++ b/setup.py
+@@ -42,7 +42,7 @@ class config_pcap(config.config):
+ dirs = [ '/usr', sys.prefix ] + glob.glob('/opt/libpcap*') + \
+ glob.glob('../libpcap*') + glob.glob('../wpdpack*')
+ for d in dirs:
+- for sd in ('include', 'include/pcap', ''):
++ for sd in ('include/pcap', 'include', ''):
+ incdirs = [ os.path.join(d, sd) ]
+ if os.path.exists(os.path.join(d, sd, 'pcap.h')):
+ cfg['include_dirs'] = [ os.path.join(d, sd) ]