summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-11-17 03:36:33 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-11-17 03:36:33 +0000
commitfb4aa5aaad22e290b767c50759b7953e7579b42c (patch)
tree992c25c4b441013077d89bda4e030c5be8ad2bae /dev-python/pypy-bin/pypy-bin-2.0.2.ebuild
parentalpha stable, bug 491034. (diff)
downloadgentoo-2-fb4aa5aaad22e290b767c50759b7953e7579b42c.tar.gz
gentoo-2-fb4aa5aaad22e290b767c50759b7953e7579b42c.tar.bz2
gentoo-2-fb4aa5aaad22e290b767c50759b7953e7579b42c.zip
pypy-bin fix for hardened profiles
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/pypy-bin/pypy-bin-2.0.2.ebuild')
-rw-r--r--dev-python/pypy-bin/pypy-bin-2.0.2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/pypy-bin/pypy-bin-2.0.2.ebuild b/dev-python/pypy-bin/pypy-bin-2.0.2.ebuild
index 79c073aaf90d..40db1e9d4320 100644
--- a/dev-python/pypy-bin/pypy-bin-2.0.2.ebuild
+++ b/dev-python/pypy-bin/pypy-bin-2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pypy-bin/pypy-bin-2.0.2.ebuild,v 1.5 2013/09/05 18:46:01 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypy-bin/pypy-bin-2.0.2.ebuild,v 1.6 2013/11/17 03:36:33 prometheanfire Exp $
EAPI=5
@@ -93,6 +93,8 @@ src_compile() {
mv pypy/module/cpyext/include/*.h include/ || die
use doc && emake -C pypy/doc/ html
+ #needed even without jit :( also needed in both compile and install phases
+ pax-mark m "${ED%/}${INSDESTTREE}/pypy-c"
}
src_test() {
@@ -107,7 +109,8 @@ src_install() {
insinto "/usr/$(get_libdir)/pypy${SLOT}"
doins -r include lib_pypy lib-python pypy-c
fperms a+x ${INSDESTTREE}/pypy-c
- use jit && pax-mark m "${ED%/}${INSDESTTREE}/pypy-c"
+ #needed even without jit :(
+ pax-mark m "${ED%/}${INSDESTTREE}/pypy-c"
dosym ../$(get_libdir)/pypy${SLOT}/pypy-c /usr/bin/pypy-c${SLOT}
dosym ../$(get_libdir)/pypy${SLOT}/include /usr/include/pypy${SLOT}
dodoc README.rst