summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-03-21 04:28:39 +0000
committerIan Delaney <idella4@gentoo.org>2014-03-21 04:28:39 +0000
commit7ed8607768506003e28943329396d113a26d83c3 (patch)
tree6ff66004347df552c9538ec214dfa71dc86b506a /dev-python/pyspf
parentold (diff)
downloadgentoo-2-7ed8607768506003e28943329396d113a26d83c3.tar.gz
gentoo-2-7ed8607768506003e28943329396d113a26d83c3.tar.bz2
gentoo-2-7ed8607768506003e28943329396d113a26d83c3.zip
revbump; Add py3 support, update deps & new PYTHON_REQ_USE setting for tests, thx to mjo for extensive testing, fixes Bugs #503266 #503264 by mjo
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyspf')
-rw-r--r--dev-python/pyspf/ChangeLog8
-rw-r--r--dev-python/pyspf/pyspf-2.0.8-r1.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/pyspf/ChangeLog b/dev-python/pyspf/ChangeLog
index 5235a602e3f4..788e48848125 100644
--- a/dev-python/pyspf/ChangeLog
+++ b/dev-python/pyspf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyspf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyspf/ChangeLog,v 1.23 2014/02/24 06:05:44 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyspf/ChangeLog,v 1.24 2014/03/21 04:28:39 idella4 Exp $
+
+*pyspf-2.0.8-r1 (21 Mar 2014)
+
+ 21 Mar 2014; Ian Delaney <idella4@gentoo.org> +pyspf-2.0.8-r1.ebuild:
+ revbump; Add py3 support, update deps & new PYTHON_REQ_USE setting for tests,
+ thx to mjo for extensive testing, fixes Bugs #503266 #503264 by mjo
*pyspf-2.0.8 (24 Feb 2014)
diff --git a/dev-python/pyspf/pyspf-2.0.8-r1.ebuild b/dev-python/pyspf/pyspf-2.0.8-r1.ebuild
new file mode 100644
index 000000000000..24aaf47caa2f
--- /dev/null
+++ b/dev-python/pyspf/pyspf-2.0.8-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyspf/pyspf-2.0.8-r1.ebuild,v 1.1 2014/03/21 04:28:39 idella4 Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_REQ_USE="ipv6" # Required for tests
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Sender Policy Framework (SPF) protocol"
+HOMEPAGE="http://pypi.python.org/pypi/pyspf"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# >=python-3.3 comes with the built-in ipaddress module
+PY23_USEDEP=$(python_gen_usedep 'python2*' python3_2)
+PY2_USEDEP=$(python_gen_usedep 'python2*')
+PY3_USEDEP=$(python_gen_usedep 'python3*')
+RDEPEND="dev-python/authres[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/ipaddr[${PY23_USEDEP}]" 'python2*' python3_2)
+ $(python_gen_cond_dep "dev-python/pydns:2[${PY2_USEDEP}]" 'python2*')
+ $(python_gen_cond_dep "dev-python/pydns:3[${PY3_USEDEP=}]" python3*)"
+
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # if a 'run' makes it to the end and there are test failures, this will always return 0.
+ # A patch is planned for submitting upstream. This state won't occur in most cases.
+ pushd test &> /dev/null
+ "${PYTHON}" testspf.py || die
+ popd &> /dev/null
+}