summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-17 07:57:02 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-17 07:57:02 +0000
commitcd291643400662b4d069b4ad3fcad82ace63006a (patch)
tree4e3110bf23598e9be56761599558ccd3e4ef582d /dev-python/pystache/pystache-0.5.4.ebuild
parentCollapse the live ebuilds, and forward-port the MULTILIB_USEDEP fix. (diff)
downloadgentoo-2-cd291643400662b4d069b4ad3fcad82ace63006a.tar.gz
gentoo-2-cd291643400662b4d069b4ad3fcad82ace63006a.tar.bz2
gentoo-2-cd291643400662b4d069b4ad3fcad82ace63006a.zip
bump; drop py2.6 add py3 pypy support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pystache/pystache-0.5.4.ebuild')
-rw-r--r--dev-python/pystache/pystache-0.5.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pystache/pystache-0.5.4.ebuild b/dev-python/pystache/pystache-0.5.4.ebuild
new file mode 100644
index 000000000000..f768272a8979
--- /dev/null
+++ b/dev-python/pystache/pystache-0.5.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pystache/pystache-0.5.4.ebuild,v 1.1 2014/05/17 07:57:02 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="Mustache for Python"
+HOMEPAGE="http://github.com/defunkt/pystache"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ nosetests || die
+ popd > /dev/null
+}