summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-09 08:00:12 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-09 08:00:12 +0000
commit88cd1cdaaa86ef4f44d7371c04c8aa4b7aa37c95 (patch)
tree0bdbb84659dc93ef820ebf71f78aa8a15c8151d0 /dev-python/pysvn/pysvn-1.7.6.ebuild
parentRemove old version. (diff)
downloadgentoo-2-88cd1cdaaa86ef4f44d7371c04c8aa4b7aa37c95.tar.gz
gentoo-2-88cd1cdaaa86ef4f44d7371c04c8aa4b7aa37c95.tar.bz2
gentoo-2-88cd1cdaaa86ef4f44d7371c04c8aa4b7aa37c95.zip
Bump/fix for #395533 #407065
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pysvn/pysvn-1.7.6.ebuild')
-rw-r--r--dev-python/pysvn/pysvn-1.7.6.ebuild107
1 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/pysvn/pysvn-1.7.6.ebuild b/dev-python/pysvn/pysvn-1.7.6.ebuild
new file mode 100644
index 000000000000..65e543c61e1c
--- /dev/null
+++ b/dev-python/pysvn/pysvn-1.7.6.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.6.ebuild,v 1.1 2012/03/09 08:00:12 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit python toolchain-funcs
+
+DESCRIPTION="Object-oriented python bindings for subversion"
+HOMEPAGE="http://pysvn.tigris.org/"
+SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-freebsd ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc examples"
+
+RDEPEND=">=dev-python/pycxx-6.2.0
+ <dev-vcs/subversion-1.8" # (bug #395533)
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+src_prepare() {
+ # Don't use internal copy of dev-python/pycxx.
+ rm -fr Import
+
+ # Fix harmless SyntaxErrors with Python 3.
+ sed -e "/^DISTDIR=/d" -i Source/pysvn_common.mak
+
+ python_copy_sources
+
+ preparation() {
+ cd Source
+ if has "${PYTHON_ABI}" 2.4 2.5; then
+ "$(PYTHON)" setup.py backport || die "Backport failed"
+ fi
+ }
+ python_execute_function -s preparation
+}
+
+src_configure() {
+ configuration() {
+ cd Source
+ "$(PYTHON)" setup.py configure \
+ --pycxx-src-dir="${EPREFIX}/usr/share/python$(python_get_version)/CXX" \
+ --apr-inc-dir="${EPREFIX}/usr/include/apr-1" \
+ --apu-inc-dir="${EPREFIX}/usr/include/apr-1" \
+ --svn-root-dir="${EPREFIX}/usr" || return 1
+
+ sed \
+ -e 's:^\(CCFLAGS=\)\(.*\):\1$(CFLAGS) \2:g' \
+ -e 's:^\(CCCFLAGS=\)\(.*\):\1$(CXXFLAGS) \2:g' \
+ -e "/^CCC=/s:g++:$(tc-getCXX):" \
+ -e "/^CC=/s:gcc:$(tc-getCC):" \
+ -e "/^LDSHARED=/s:g++:$(tc-getCXX) ${LDFLAGS}:" \
+ -i Makefile || die "sed failed"
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ building() {
+ cd Source
+ emake
+ }
+ python_execute_function -s building
+}
+
+src_test() {
+ testing() {
+ cd Source
+ emake test || return 1
+ emake -C ../Tests || return 1
+ }
+ python_execute_function -s testing
+}
+
+src_install() {
+ installation() {
+ cd Source/pysvn
+ exeinto "$(python_get_sitedir)/pysvn"
+ doexe _pysvn*$(get_modname) || die "doexe failed"
+ insinto "$(python_get_sitedir)/pysvn"
+ doins __init__.py || die "doins failed"
+ }
+ python_execute_function -s installation
+
+ if use doc; then
+ dohtml -r Docs/ || die "dohtml failed"
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc Examples/Client/* || die "dodoc examples failed"
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize pysvn
+}
+
+pkg_postrm() {
+ python_mod_cleanup pysvn
+}