summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-10-08 20:26:21 +0000
committerFabian Groffen <grobian@gentoo.org>2009-10-08 20:26:21 +0000
commit469ece65848ded0083e74570a6e15fadd40ef5c8 (patch)
treefa924afb93f25c32575e5de22ebcbb2d356137a5 /dev-python/pysvn
parentadd Prefix compatability (diff)
downloadgentoo-2-469ece65848ded0083e74570a6e15fadd40ef5c8.tar.gz
gentoo-2-469ece65848ded0083e74570a6e15fadd40ef5c8.tar.bz2
gentoo-2-469ece65848ded0083e74570a6e15fadd40ef5c8.zip
Fix for and keyword ~x86-freebsd and ~ppc-macos, thanks Michael Yang for the FreeBSD part of the patch, bug #287608
(Portage version: 2.2.00.14487-prefix/cvs/Darwin powerpc, RepoMan options: --force)
Diffstat (limited to 'dev-python/pysvn')
-rw-r--r--dev-python/pysvn/ChangeLog7
-rw-r--r--dev-python/pysvn/files/pysvn-1.7.0-darwin-freebsd.patch80
-rw-r--r--dev-python/pysvn/pysvn-1.7.0.ebuild15
3 files changed, 96 insertions, 6 deletions
diff --git a/dev-python/pysvn/ChangeLog b/dev-python/pysvn/ChangeLog
index 049889f163c2..7048c6473fb4 100644
--- a/dev-python/pysvn/ChangeLog
+++ b/dev-python/pysvn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pysvn
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.3 2009/09/04 18:43:35 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.4 2009/10/08 20:26:20 grobian Exp $
+
+ 08 Oct 2009; Fabian Groffen <grobian@gentoo.org> pysvn-1.7.0.ebuild,
+ +files/pysvn-1.7.0-darwin-freebsd.patch:
+ Fix for and keyword ~x86-freebsd and ~ppc-macos, thanks Michael Yang for
+ the FreeBSD part of the patch, bug #287608
04 Sep 2009; Patrick Lauer <patrick@gentoo.org> -pysvn-1.6.3-r1.ebuild:
Remove old
diff --git a/dev-python/pysvn/files/pysvn-1.7.0-darwin-freebsd.patch b/dev-python/pysvn/files/pysvn-1.7.0-darwin-freebsd.patch
new file mode 100644
index 000000000000..a2ec45ff3ae8
--- /dev/null
+++ b/dev-python/pysvn/files/pysvn-1.7.0-darwin-freebsd.patch
@@ -0,0 +1,80 @@
+FreeBSD:
+http://bugs.gentoo.org/show_bug.cgi?id=287608
+Darwin:
+build bundles, don't do Fink or MacPorts detection, don't use deprecated
+-Wno-long-long-double, don't inject some broken framework path
+
+--- Source/setup_configure.py
++++ Source/setup_configure.py
+@@ -177,6 +177,8 @@
+ module_type = '.so'
+ if self.platform == 'cygwin':
+ module_type = '.dll'
++ if self.is_mac_os_x:
++ module_type = '.bundle'
+
+ if '--fixed-module-name' in argv:
+ print( 'Info: Using fixed module name' )
+@@ -249,21 +249,15 @@
+
+ # 10.4 needs the libintl.a but 10.3 does not
+ template_values['extra_libs'] = '%(svn_lib_dir)s/libintl.a' % template_values
+- template_values['frameworks'] = '-framework System %s -framework CoreFoundation -framework Kerberos -framework Security' % framework_lib
++ template_values['frameworks'] = '-framework System -framework CoreFoundation -framework Kerberos -framework Security -lpython'
+ else:
+ if self.verbose:
+ print( 'Info: Using Mac OS X 10.3 makefile template' )
+
+ template_values['extra_libs'] = ''
+- template_values['frameworks'] = '-framework System %s -framework CoreFoundation' % framework_lib
++ template_values['frameworks'] = '-framework System -framework CoreFoundation -lpython'
+
+- if self.is_mac_os_x_fink:
+- makefile.write( self.makefile_template_macosx_fink % template_values )
+-
+- elif self.is_mac_os_x_darwin_ports:
+- makefile.write( self.makefile_template_macosx_darwin_ports % template_values )
+-
+- elif self.mac_os_x_universal:
++ if self.mac_os_x_universal:
+ template_values[ 'mac_os_x_sdk' ] = self.mac_os_x_sdk
+ if sys.version_info[0] >= 3:
+ makefile.write( self.makefile_template_macosx_universal_py3 % template_values )
+@@ -447,11 +429,11 @@
+ PYCXX=%(pycxx_dir)s
+ PYCXXSRC=%(pycxx_src_dir)s
+ LDSHARED=g++ -shared %(debug_cflags)s
+-LDLIBS=-L%(svn_lib_dir)s -Wl,--rpath -Wl,/usr/lib:/usr/local/lib:%(svn_lib_dir)s \
++LDLIBS=-L%(svn_lib_dir)s -Wl,--rpath -Wl,%(svn_lib_dir)s \
+ -lsvn_client-1 \
+ -lsvn_diff-1 \
+ -lsvn_repos-1 \
+- -lkrb5 -lcom_err -lexpat -lneon
++ -lcom_err -lexpat -lneon
+
+ #include pysvn_common.mak
+ '''
+@@ -538,9 +538,9 @@
+ PYTHON=%(python_exe)s
+ SVN_INCLUDE=%(svn_include)s
+ CCC=g++
+-CCCFLAGS=-Wall -Wno-long-double -fPIC -fexceptions -frtti %(includes)s %(py_cflags)s %(debug_cflags)s
++CCCFLAGS=-Wall -fPIC -fexceptions -frtti %(includes)s %(py_cflags)s %(debug_cflags)s
+ CC=gcc
+-CCFLAGS=-Wall -Wno-long-double -fPIC %(includes)s %(debug_cflags)s
++CCFLAGS=-Wall -fPIC %(includes)s %(debug_cflags)s
+ PYCXX=%(pycxx_dir)s
+ PYCXXSRC=%(pycxx_src_dir)s
+ LDSHARED=g++ -bundle %(debug_cflags)s -u _PyMac_Error %(frameworks)s
+@@ -563,9 +563,9 @@
+ PYTHON=%(python_exe)s
+ SVN_INCLUDE=%(svn_include)s
+ CCC=g++
+-CCCFLAGS=-Wall -Wno-long-double -fPIC -fexceptions -frtti %(includes)s %(py_cflags)s %(debug_cflags)s
++CCCFLAGS=-Wall -fPIC -fexceptions -frtti %(includes)s %(py_cflags)s %(debug_cflags)s
+ CC=gcc
+-CCFLAGS=-Wall -Wno-long-double -fPIC %(includes)s %(debug_cflags)s
++CCFLAGS=-Wall -fPIC %(includes)s %(debug_cflags)s
+ PYCXX=%(pycxx_dir)s
+ PYCXXSRC=%(pycxx_src_dir)s
+ LDSHARED=g++ -bundle %(debug_cflags)s %(frameworks)s
diff --git a/dev-python/pysvn/pysvn-1.7.0.ebuild b/dev-python/pysvn/pysvn-1.7.0.ebuild
index 01e778319cc6..f6d521dfc629 100644
--- a/dev-python/pysvn/pysvn-1.7.0.ebuild
+++ b/dev-python/pysvn/pysvn-1.7.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.0.ebuild,v 1.1 2009/06/21 10:32:45 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.0.ebuild,v 1.2 2009/10/08 20:26:20 grobian Exp $
-inherit eutils python toolchain-funcs
+inherit eutils multilib python toolchain-funcs
DESCRIPTION="Object-oriented python bindings for subversion"
HOMEPAGE="http://pysvn.tigris.org/"
@@ -10,7 +10,7 @@ SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
LICENSE="Apache-1.1"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-freebsd ~ppc-macos"
IUSE="doc examples"
DEPEND="dev-util/subversion"
@@ -29,6 +29,7 @@ src_unpack() {
epatch "${FILESDIR}/skip-root-test.patch"
cd "${S}"
+ epatch "${FILESDIR}"/${P}-darwin-freebsd.patch
# since pysvn-1.6.3: These sources are not compatible with python =< 2.5
# run the backport command to fix
@@ -38,13 +39,17 @@ src_unpack() {
fi
# needed to generate the Makefile
- python setup.py configure || die "configure failed"
+ python setup.py configure \
+ --apr-inc-dir="${EPREFIX}"/usr/include/apr-1 \
+ --svn-root-dir="${EPREFIX}"/usr \
+ || die "configure failed"
# we want our CFLAGS as well
sed -e 's:^\(CCFLAGS=\)\(.*\):\1$(CFLAGS) \2:g' \
-e 's:^\(CCCFLAGS=\)\(.*\):\1$(CXXFLAGS) \2:g' \
-e "/^CCC=/s:g++:$(tc-getCXX):" \
-e "/^CC=/s:gcc:$(tc-getCC):" \
+ -e "/^LDSHARED=/s:g++:$(tc-getCXX):" \
-i Makefile \
|| die "sed failed in Makefile"
}
@@ -62,7 +67,7 @@ src_install() {
cd pysvn/
exeinto ${sitedir}
- doexe _pysvn*.so || die "doexe failed"
+ doexe _pysvn*$(get_modname) || die "doexe failed"
insinto ${sitedir}
doins __init__.py || die "doins failed"