summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-04-04 12:38:16 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-04-04 12:38:16 +0000
commit3a08aea303a1b7e343617494b614bbbc0ade5ede (patch)
treed960018d7c8aa1bed883364736c5490c3d6af20e /dev-python/pytest/pytest-2.3.4.ebuild
parentSilence repoman. (diff)
downloadgentoo-2-3a08aea303a1b7e343617494b614bbbc0ade5ede.tar.gz
gentoo-2-3a08aea303a1b7e343617494b614bbbc0ade5ede.tar.bz2
gentoo-2-3a08aea303a1b7e343617494b614bbbc0ade5ede.zip
Restore stable keywords
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, RepoMan options: --force, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pytest/pytest-2.3.4.ebuild')
-rw-r--r--dev-python/pytest/pytest-2.3.4.ebuild16
1 files changed, 4 insertions, 12 deletions
diff --git a/dev-python/pytest/pytest-2.3.4.ebuild b/dev-python/pytest/pytest-2.3.4.ebuild
index 41e0365148d5..dcd51a7feadf 100644
--- a/dev-python/pytest/pytest-2.3.4.ebuild
+++ b/dev-python/pytest/pytest-2.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.4.ebuild,v 1.15 2013/04/04 09:14:30 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.4.ebuild,v 1.16 2013/04/04 12:38:16 patrick Exp $
EAPI="5"
@@ -13,12 +13,12 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="alpha ~amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="doc test"
# When bumping, please check setup.py for the proper py version
PY_VER="1.4.12"
-RDEPEND=">=dev-python/py-${PY_VER}"
+RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
app-arch/unzip
dev-python/setuptools[${PYTHON_USEDEP}]"
@@ -43,15 +43,7 @@ python_compile_all() {
}
python_test() {
- cd "${BUILD_DIR}"/lib/ || die
- # pytest.py draws from "${S}" if / when absent of a local testing folder; Bug 462552
- if [[ "${EPYTHON:6:1}" == 3 ]]; then
- cp -a "${S}"/testing/ . || die
- "${PYTHON}" pytest.py || die "tests failed with ${EPYTHON}"
- rm -rf testing/
- else
- "${PYTHON}" pytest.py || die "tests failed with ${EPYTHON}"
- fi
+ "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py || die "tests failed with ${EPYTHON}"
}
python_install_all() {