summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-05-03 14:10:34 +0000
committerJustin Lecher <jlec@gentoo.org>2011-05-03 14:10:34 +0000
commit2661209b6871a8438e89201de4c5cb7a24d30740 (patch)
tree27f4bad5a329394415f05e22ab988bc6c07bc724 /dev-python/python-bibtex/python-bibtex-1.2.5.ebuild
parentStable on amd64 wrt bug #360315 (diff)
downloadgentoo-2-2661209b6871a8438e89201de4c5cb7a24d30740.tar.gz
gentoo-2-2661209b6871a8438e89201de4c5cb7a24d30740.tar.bz2
gentoo-2-2661209b6871a8438e89201de4c5cb7a24d30740.zip
Non-maintainer version bump, fix slotting for gnome3
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-bibtex/python-bibtex-1.2.5.ebuild')
-rw-r--r--dev-python/python-bibtex/python-bibtex-1.2.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-bibtex/python-bibtex-1.2.5.ebuild b/dev-python/python-bibtex/python-bibtex-1.2.5.ebuild
new file mode 100644
index 000000000000..6ca31af27b69
--- /dev/null
+++ b/dev-python/python-bibtex/python-bibtex-1.2.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-bibtex/python-bibtex-1.2.5.ebuild,v 1.1 2011/05/03 14:10:34 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="A Python extension to parse BibTeX files"
+HOMEPAGE="http://pybliographer.org/"
+SRC_URI="mirror://sourceforge/pybliographer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ >=app-text/recode-3.6-r1"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable tests during installation.
+ sed -e "/self.run_command ('check')/d" -i setup.py
+}
+
+src_test() {
+ testing() {
+ "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" check
+ }
+ python_execute_function testing
+}