summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-05-16 01:21:30 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-05-16 01:21:30 +0000
commit36d6e93e6a51cfd2984678149cd4d389dd2c4e02 (patch)
tree5f9327def337599d66d130fa9223248043531cf4 /dev-python/python-cinderclient
parentupdated dep on webob for 2013.1.1 to support eapi5 distutils-r1 (diff)
downloadgentoo-2-36d6e93e6a51cfd2984678149cd4d389dd2c4e02.tar.gz
gentoo-2-36d6e93e6a51cfd2984678149cd4d389dd2c4e02.tar.bz2
gentoo-2-36d6e93e6a51cfd2984678149cd4d389dd2c4e02.zip
updating cinderclient to remove conflict with novaclient
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-cinderclient')
-rw-r--r--dev-python/python-cinderclient/ChangeLog8
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-1.0.4.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/python-cinderclient/ChangeLog b/dev-python/python-cinderclient/ChangeLog
index 41f5618909dd..a620f3b447e0 100644
--- a/dev-python/python-cinderclient/ChangeLog
+++ b/dev-python/python-cinderclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-cinderclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/ChangeLog,v 1.3 2013/03/19 22:39:59 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/ChangeLog,v 1.4 2013/05/16 01:21:30 prometheanfire Exp $
+
+*python-cinderclient-1.0.4 (16 May 2013)
+
+ 16 May 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +python-cinderclient-1.0.4.ebuild:
+ updating cinderclient to remove conflict with novaclient
19 Mar 2013; Matthew Thode <prometheanfire@gentoo.org>
python-cinderclient-1.0.2.ebuild:
diff --git a/dev-python/python-cinderclient/python-cinderclient-1.0.4.ebuild b/dev-python/python-cinderclient/python-cinderclient-1.0.4.ebuild
new file mode 100644
index 000000000000..0acd8aab8459
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-1.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/python-cinderclient-1.0.4.ebuild,v 1.1 2013/05/16 01:21:30 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nosehtmloutput[${PYTHON_USEDEP}]
+ dev-python/nosexcover
+ dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
+ =dev-python/pep8-1.3.3
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.22 )"
+RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/requests-0.8[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]"
+
+python_test() {
+ sh run_tests.sh -N -p -c
+}