summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-31 22:31:29 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-31 22:31:29 +0000
commitd6382562896d1ec91270218c26a5f543b3bd0f03 (patch)
tree4120fa260f5b01d10ce28929ebebdb8406339d6d /dev-python/python-daemon/python-daemon-1.6-r1.ebuild
parentRevision bump, migrate to distutils-r1. (diff)
downloadgentoo-2-d6382562896d1ec91270218c26a5f543b3bd0f03.tar.gz
gentoo-2-d6382562896d1ec91270218c26a5f543b3bd0f03.tar.bz2
gentoo-2-d6382562896d1ec91270218c26a5f543b3bd0f03.zip
Revision bump, migrate to distutils-r1.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/python-daemon/python-daemon-1.6-r1.ebuild')
-rw-r--r--dev-python/python-daemon/python-daemon-1.6-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-daemon/python-daemon-1.6-r1.ebuild b/dev-python/python-daemon/python-daemon-1.6-r1.ebuild
new file mode 100644
index 000000000000..5762c3bb6e1b
--- /dev/null
+++ b/dev-python/python-daemon/python-daemon-1.6-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-daemon/python-daemon-1.6-r1.ebuild,v 1.1 2013/05/31 22:31:29 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to implement a well-behaved Unix daemon process."
+HOMEPAGE="http://pypi.python.org/pypi/python-daemon"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/lockfile-0.9[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/minimock[${PYTHON_USEDEP}] )"
+
+DOCS=( ChangeLog )
+
+python_test() {
+ esetup.py test
+}