summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-12-10 18:56:32 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-12-10 18:56:32 +0000
commit76e6a534320fffdc3cd4e52267b461d24eec0367 (patch)
tree88eee73217f89865dc7150adc0976bfbd8c1e89c /dev-python/python-docs/python-docs-3.2.2.ebuild
parentStabilize for all #393949 by Paweł Hajdan. (diff)
downloadgentoo-2-76e6a534320fffdc3cd4e52267b461d24eec0367.tar.gz
gentoo-2-76e6a534320fffdc3cd4e52267b461d24eec0367.tar.bz2
gentoo-2-76e6a534320fffdc3cd4e52267b461d24eec0367.zip
Version bump thanks to Arfrever
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-docs/python-docs-3.2.2.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-3.2.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-3.2.2.ebuild b/dev-python/python-docs/python-docs-3.2.2.ebuild
new file mode 100644
index 000000000000..c444f9b55dab
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.2.2.ebuild,v 1.1 2011/12/10 18:56:32 hwoarang Exp $
+
+EAPI="3"
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2"
+SLOT="3.2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+pkg_postrm() {
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${EROOT}etc/env.d/65python-docs"
+ fi
+}