summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-25 17:00:56 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-25 17:00:56 +0000
commite143baa744bce81023a5687a94114dfc5cc84462 (patch)
treed11809a2806b09d22e24fc9a3394db1f431df312 /dev-python/python-iwscan
parentFix dependencies. Set SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-e143baa744bce81023a5687a94114dfc5cc84462.tar.gz
gentoo-2-e143baa744bce81023a5687a94114dfc5cc84462.tar.bz2
gentoo-2-e143baa744bce81023a5687a94114dfc5cc84462.zip
Fix dependencies. Set SUPPORT_PYTHON_ABIS. Avoid breaking strict-aliasing rules.
(Portage version: 2.2.0_alpha10_p8/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-iwscan')
-rw-r--r--dev-python/python-iwscan/ChangeLog6
-rw-r--r--dev-python/python-iwscan/python-iwscan-20080402.ebuild11
2 files changed, 14 insertions, 3 deletions
diff --git a/dev-python/python-iwscan/ChangeLog b/dev-python/python-iwscan/ChangeLog
index a03719b94b70..7b70132b491d 100644
--- a/dev-python/python-iwscan/ChangeLog
+++ b/dev-python/python-iwscan/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/python-iwscan
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iwscan/ChangeLog,v 1.11 2010/12/20 23:45:22 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iwscan/ChangeLog,v 1.12 2010/12/25 17:00:56 arfrever Exp $
+
+ 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-iwscan-20080402.ebuild:
+ Fix dependencies. Set SUPPORT_PYTHON_ABIS. Avoid breaking strict-aliasing rules.
20 Dec 2010; Jeremy Olexa <darkside@gentoo.org> metadata.xml:
remove myself as maintainer
diff --git a/dev-python/python-iwscan/python-iwscan-20080402.ebuild b/dev-python/python-iwscan/python-iwscan-20080402.ebuild
index 314a9bb5b170..3d932d73d1ef 100644
--- a/dev-python/python-iwscan/python-iwscan-20080402.ebuild
+++ b/dev-python/python-iwscan/python-iwscan-20080402.ebuild
@@ -1,6 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iwscan/python-iwscan-20080402.ebuild,v 1.8 2009/11/30 06:37:18 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iwscan/python-iwscan-20080402.ebuild,v 1.9 2010/12/25 17:00:56 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils
@@ -15,3 +20,5 @@ IUSE=""
DEPEND=""
RDEPEND=""
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")