summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-05 07:36:48 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-05 07:36:48 +0000
commit99d540e9dd76ed2007d76bcf5b20a96bd171f537 (patch)
tree369e1a4f01c732432f6d7b67fa7c5261c1419c43 /dev-python/python-lzo
parentrevbump; conversion -> distutils-r1, rm old (diff)
downloadgentoo-2-99d540e9dd76ed2007d76bcf5b20a96bd171f537.tar.gz
gentoo-2-99d540e9dd76ed2007d76bcf5b20a96bd171f537.tar.bz2
gentoo-2-99d540e9dd76ed2007d76bcf5b20a96bd171f537.zip
revbump; conversion -> distutils-r1, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-lzo')
-rw-r--r--dev-python/python-lzo/ChangeLog11
-rw-r--r--dev-python/python-lzo/python-lzo-1.08-r1.ebuild26
-rw-r--r--dev-python/python-lzo/python-lzo-1.08.ebuild34
3 files changed, 34 insertions, 37 deletions
diff --git a/dev-python/python-lzo/ChangeLog b/dev-python/python-lzo/ChangeLog
index be51dfd08229..11c5dd9b6488 100644
--- a/dev-python/python-lzo/ChangeLog
+++ b/dev-python/python-lzo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-lzo
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-lzo/ChangeLog,v 1.7 2011/07/22 12:03:45 neurogeek Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-lzo/ChangeLog,v 1.8 2015/01/05 07:36:48 idella4 Exp $
+
+*python-lzo-1.08-r1 (05 Jan 2015)
+
+ 05 Jan 2015; Ian Delaney <idella4@gentoo.org> +python-lzo-1.08-r1.ebuild,
+ -python-lzo-1.08.ebuild:
+ revbump; conversion -> distutils-r1, rm old
22 Jul 2011; Jesus Rivero <neurogeek@gentoo.org> metadata.xml:
Changed herd to python
@@ -27,4 +33,3 @@
14 Apr 2007; Daniel Black <dragonheart@gentoo.org>
+files/lzo2compat.patch, +metadata.xml, +python-lzo-1.08.ebuild:
inital ebuild thanks to request from Michael R. Lawrence in bug #158474
-
diff --git a/dev-python/python-lzo/python-lzo-1.08-r1.ebuild b/dev-python/python-lzo/python-lzo-1.08-r1.ebuild
new file mode 100644
index 000000000000..aba3ebf8b2ea
--- /dev/null
+++ b/dev-python/python-lzo/python-lzo-1.08-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-lzo/python-lzo-1.08-r1.ebuild,v 1.1 2015/01/05 07:36:48 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to lzo"
+HOMEPAGE="http://www.oberhumer.com/opensource/lzo/"
+SRC_URI="http://www.oberhumer.com/opensource/lzo/download/LZO-v1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/lzo:2"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/lzo2compat.patch" )
+
+python_test() {
+ "${PYTHON}" tests/test.py || die "tests failed"
+}
diff --git a/dev-python/python-lzo/python-lzo-1.08.ebuild b/dev-python/python-lzo/python-lzo-1.08.ebuild
deleted file mode 100644
index a6a4fefb9159..000000000000
--- a/dev-python/python-lzo/python-lzo-1.08.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-lzo/python-lzo-1.08.ebuild,v 1.3 2011/02/26 23:24:28 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit distutils eutils
-
-DESCRIPTION="Python interface to lzo"
-HOMEPAGE="http://www.oberhumer.com/opensource/lzo/"
-SRC_URI="http://www.oberhumer.com/opensource/lzo/download/LZO-v1/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-libs/lzo:2"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/lzo2compat.patch"
-}
-
-src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" tests/test.py
- }
- python_execute_function testing
-}