summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-06 03:59:21 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-06 03:59:21 +0000
commit0065e31be70ccbb6c8f0f2a8789c5daa31bcf393 (patch)
treeebed01568fa6420b7e217b98df5d5aab5d97e476 /dev-python/python-urljr
parentVersion bump. (diff)
downloadgentoo-2-0065e31be70ccbb6c8f0f2a8789c5daa31bcf393.tar.gz
gentoo-2-0065e31be70ccbb6c8f0f2a8789c5daa31bcf393.tar.bz2
gentoo-2-0065e31be70ccbb6c8f0f2a8789c5daa31bcf393.zip
revbump; conversion -> distutils-r1, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-urljr')
-rw-r--r--dev-python/python-urljr/ChangeLog11
-rw-r--r--dev-python/python-urljr/python-urljr-1.0.1-r1.ebuild28
-rw-r--r--dev-python/python-urljr/python-urljr-1.0.1.ebuild39
3 files changed, 36 insertions, 42 deletions
diff --git a/dev-python/python-urljr/ChangeLog b/dev-python/python-urljr/ChangeLog
index 716ced5cd066..4011abc86b74 100644
--- a/dev-python/python-urljr/ChangeLog
+++ b/dev-python/python-urljr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-urljr
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-urljr/ChangeLog,v 1.3 2010/07/08 16:08:43 arfrever Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-urljr/ChangeLog,v 1.4 2015/01/06 03:59:21 idella4 Exp $
+
+*python-urljr-1.0.1-r1 (06 Jan 2015)
+
+ 06 Jan 2015; Ian Delaney <idella4@gentoo.org> +python-urljr-1.0.1-r1.ebuild,
+ -python-urljr-1.0.1.ebuild:
+ revbump; conversion -> distutils-r1, rm old
08 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
python-urljr-1.0.1.ebuild:
@@ -16,4 +22,3 @@
+files/python-urljr-1.0.1-gentoo-test_fetchers.patch,
+python-urljr-1.0.1.ebuild:
Initial commit.
-
diff --git a/dev-python/python-urljr/python-urljr-1.0.1-r1.ebuild b/dev-python/python-urljr/python-urljr-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..5fa15ff5cc94
--- /dev/null
+++ b/dev-python/python-urljr/python-urljr-1.0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-urljr/python-urljr-1.0.1-r1.ebuild,v 1.1 2015/01/06 03:59:21 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="JanRain's URL Utilities"
+HOMEPAGE="http://www.openidenabled.com/openid/libraries/python/"
+SRC_URI="http://www.openidenabled.com/resources/downloads/python-openid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl test"
+
+RDEPEND="curl? ( >=dev-python/pycurl-7.15.1[${PYTHON_USEDEP}] )"
+DEPEND=""
+
+REQUIRED_USE="test? ( curl )"
+# test fails if it finds 'localhost' instead of '127.0.0.1'
+PATCHES=( "${FILESDIR}/${P}-gentoo-test_fetchers.patch" )
+
+python_test() {
+ PYTHONPATH=. "${PYTHON}" admin/runtests || die "tests failed"
+}
diff --git a/dev-python/python-urljr/python-urljr-1.0.1.ebuild b/dev-python/python-urljr/python-urljr-1.0.1.ebuild
deleted file mode 100644
index 6a2781f10e1f..000000000000
--- a/dev-python/python-urljr/python-urljr-1.0.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-urljr/python-urljr-1.0.1.ebuild,v 1.4 2010/07/08 16:08:43 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils eutils
-
-DESCRIPTION="JanRain's URL Utilities"
-HOMEPAGE="http://www.openidenabled.com/openid/libraries/python/"
-SRC_URI="http://www.openidenabled.com/resources/downloads/python-openid/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="curl test"
-
-RDEPEND="curl? ( >=dev-python/pycurl-7.15.1 )"
-DEPEND="${RDEPEND}
- test? ( >=dev-python/pycurl-7.15.1 )"
-
-PYTHON_MODNAME="urljr"
-
-src_prepare() {
- distutils_src_prepare
-
- # Test fails if it finds 'localhost' instead of '127.0.0.1'.
- epatch "${FILESDIR}/${P}-gentoo-test_fetchers.patch"
-}
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" admin/runtests
- }
- python_execute_function testing
-}