summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-01 19:40:45 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-01 19:40:45 +0000
commitf02e0a97b9f5cca7a46b5d3fe7d60014a4e6f722 (patch)
treee8f7f569442068514f8f56b50d1daa8bab36be47 /dev-python/pythoncard
parentDelete older ebuild. (diff)
downloadgentoo-2-f02e0a97b9f5cca7a46b5d3fe7d60014a4e6f722.tar.gz
gentoo-2-f02e0a97b9f5cca7a46b5d3fe7d60014a4e6f722.tar.bz2
gentoo-2-f02e0a97b9f5cca7a46b5d3fe7d60014a4e6f722.zip
Fix dependencies. Set SUPPORT_PYTHON_ABIS.
(Portage version: 2.2.0_alpha11_p6/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pythoncard')
-rw-r--r--dev-python/pythoncard/ChangeLog6
-rw-r--r--dev-python/pythoncard/pythoncard-0.8.2.ebuild28
2 files changed, 29 insertions, 5 deletions
diff --git a/dev-python/pythoncard/ChangeLog b/dev-python/pythoncard/ChangeLog
index 16e94e6e78f9..64d6ec3779a6 100644
--- a/dev-python/pythoncard/ChangeLog
+++ b/dev-python/pythoncard/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pythoncard
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythoncard/ChangeLog,v 1.21 2011/01/01 19:39:29 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythoncard/ChangeLog,v 1.22 2011/01/01 19:40:45 arfrever Exp $
+
+ 01 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pythoncard-0.8.2.ebuild:
+ Fix dependencies. Set SUPPORT_PYTHON_ABIS.
01 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-pythoncard-0.7.3.1.ebuild:
diff --git a/dev-python/pythoncard/pythoncard-0.8.2.ebuild b/dev-python/pythoncard/pythoncard-0.8.2.ebuild
index 2641746e7cf2..05310836fa90 100644
--- a/dev-python/pythoncard/pythoncard-0.8.2.ebuild
+++ b/dev-python/pythoncard/pythoncard-0.8.2.ebuild
@@ -1,10 +1,15 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythoncard/pythoncard-0.8.2.ebuild,v 1.3 2007/10/03 04:45:50 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythoncard/pythoncard-0.8.2.ebuild,v 1.4 2011/01/01 19:40:45 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils
-MY_P=PythonCard-${PV}
+MY_P="PythonCard-${PV}"
DESCRIPTION="Cross-platform GUI construction kit for python"
HOMEPAGE="http://pythoncard.sourceforge.net/index.html"
@@ -18,10 +23,25 @@ IUSE=""
DEPEND="=dev-python/wxpython-2.6*"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+PYTHON_MODNAME="PythonCard"
+
+src_compile() {
+ :
+}
src_install() {
distutils_src_install
+
+ # install-pythoncard.py is only for Windows.
+ rm -f "${ED}usr/bin/install-pythoncard.py"
+
dohtml -r docs/html/*
dodoc docs/*.txt
}
+
+pkg_postinst() {
+ python_mod_optimize -x "/(docs|samples|tools)/" PythonCard
+}