summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-11-23 12:25:43 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-11-23 12:25:43 +0000
commit1694c0e4aa2d81b6a93617dd288578c896f6c12b (patch)
tree83bb5e92658017b6201bb89a947b9036afe7db17 /dev-python/pythong/pythong-2.1.4.ebuild
parentversion bump and cleanups (diff)
downloadgentoo-2-1694c0e4aa2d81b6a93617dd288578c896f6c12b.tar.gz
gentoo-2-1694c0e4aa2d81b6a93617dd288578c896f6c12b.tar.bz2
gentoo-2-1694c0e4aa2d81b6a93617dd288578c896f6c12b.zip
version bump and cleanups
Diffstat (limited to 'dev-python/pythong/pythong-2.1.4.ebuild')
-rw-r--r--dev-python/pythong/pythong-2.1.4.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pythong/pythong-2.1.4.ebuild b/dev-python/pythong/pythong-2.1.4.ebuild
new file mode 100644
index 000000000000..b13719a09278
--- /dev/null
+++ b/dev-python/pythong/pythong-2.1.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythong/pythong-2.1.4.ebuild,v 1.1 2003/11/23 12:25:37 liquidx Exp $
+
+inherit python distutils
+
+MY_PN="pythonG"
+MY_PV=${PV/_/-}
+MY_PV=$(echo $MY_PV | sed -e 's:\.:_:g')
+
+DESCRIPTION="Nice and powerful spanish development enviroment for Python"
+SRC_URI="http://www3.uji.es/~dllorens/downloads/pythong/linux/${MY_PN}-${MY_PV}.tgz
+ doc? ( http://marmota.act.uji.es/MTP/pdf/python.pdf )"
+HOMEPAGE="http://www3.uji.es/~dllorens/PythonG/principal.html"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE="doc"
+
+S=${WORKDIR}/${MY_PN}-${MY_PV}
+
+RDEPEND=">=dev-lang/python-2.2.2
+ >=dev-lang/tk-8.3.4
+ >=dev-python/pmw-1.2"
+
+pkg_setup() {
+ if ! python_mod_exists Tkinter; then
+ eerror "You need to Tk support in Python to continue. Try running:"
+ eerror "USE=\"tcltk\" emerge python"
+ die "Missing Tkinter support"
+ fi
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+
+ python_version
+
+ insinto /usr/lib/python${PYVER}/site-packages/
+ doins modulepythong.py
+ doins libpythong/fromidle.py
+
+ exeinto /usr/bin
+ doexe pythong.py
+
+ dodoc leeme.txt
+ cp -r ${S}/{LICENCIA,MANUAL,demos} ${D}/usr/share/doc/${PF}
+ rm -f ${D}/usr/share/doc/${PF}/demos/modulepythong.py
+
+ if [ -n "`use doc`" ]; then
+ insinto /usr/share/doc/${PF}
+ doins ${DISTDIR}/python.pdf
+ fi
+
+}