summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-11-23 08:43:53 +0000
committerJustin Lecher <jlec@gentoo.org>2013-11-23 08:43:53 +0000
commitdcf06dd4f845327180734c5763277903ad0b9943 (patch)
tree53006c78dbbc7e7ca290798b39ee86bbeedf9c6d /dev-python/pytools/pytools-9999.ebuild
parentdev-tcltk/tclreadline: Add multiple fixes imported from debian and kindly pro... (diff)
downloadgentoo-2-dcf06dd4f845327180734c5763277903ad0b9943.tar.gz
gentoo-2-dcf06dd4f845327180734c5763277903ad0b9943.tar.bz2
gentoo-2-dcf06dd4f845327180734c5763277903ad0b9943.zip
dev-python/pytools: Version Bump to fix #484262; drop old
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/pytools/pytools-9999.ebuild')
-rw-r--r--dev-python/pytools/pytools-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-python/pytools/pytools-9999.ebuild b/dev-python/pytools/pytools-9999.ebuild
index 6a4caf7883fe..92059a609fda 100644
--- a/dev-python/pytools/pytools-9999.ebuild
+++ b/dev-python/pytools/pytools-9999.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytools/pytools-9999.ebuild,v 1.6 2013/09/05 18:46:05 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytools/pytools-9999.ebuild,v 1.7 2013/11/23 08:43:53 jlec Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+EGIT_NONSHALLOW=true
-inherit distutils-r1 git-2
+inherit distutils-r1 git-r3
DESCRIPTION="A collection of tools missing from the Python standard library"
HOMEPAGE="http://mathema.tician.de/software/pytools"
@@ -19,11 +20,10 @@ IUSE="test"
DEPEND="
>=dev-python/setuptools-0.7.2[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}] )"
+ dev-python/decorator[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
RDEPEND=""
python_test() {
- py.test || die "Tests fail with ${EPYTHON}"
+ py.test -v || die "Tests fail with ${EPYTHON}"
}