summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-06-23 15:28:42 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-06-23 15:28:42 +0000
commit83b01fde15f166976019ec6cf7347f5315f979dd (patch)
tree16f8cb81f38dd66b485ed42c622f03beec717fd0 /dev-python/pytz
parentMarking lftp-4.2.3 ppc for bug 369681 (diff)
downloadgentoo-2-83b01fde15f166976019ec6cf7347f5315f979dd.tar.gz
gentoo-2-83b01fde15f166976019ec6cf7347f5315f979dd.tar.bz2
gentoo-2-83b01fde15f166976019ec6cf7347f5315f979dd.zip
Bring back deleted file which was stable for ppc64
(Portage version: 2.1.9.49/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-python/pytz')
-rw-r--r--dev-python/pytz/ChangeLog5
-rw-r--r--dev-python/pytz/pytz-2011d.ebuild46
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/pytz/ChangeLog b/dev-python/pytz/ChangeLog
index 5c0d0b5bb96c..1f8d60399990 100644
--- a/dev-python/pytz/ChangeLog
+++ b/dev-python/pytz/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pytz
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytz/ChangeLog,v 1.112 2011/06/23 14:54:34 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytz/ChangeLog,v 1.113 2011/06/23 15:28:42 hwoarang Exp $
+
+ 23 Jun 2011; Markos Chandras <hwoarang@gentoo.org> +pytz-2011d.ebuild:
+ Bring back deleted file which was stable for ppc64
23 Jun 2011; Markos Chandras <hwoarang@gentoo.org> -pytz-2011b.ebuild,
-pytz-2011c.ebuild, -pytz-2011d.ebuild:
diff --git a/dev-python/pytz/pytz-2011d.ebuild b/dev-python/pytz/pytz-2011d.ebuild
new file mode 100644
index 000000000000..1fc1a98e01be
--- /dev/null
+++ b/dev-python/pytz/pytz-2011d.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytz/pytz-2011d.ebuild,v 1.8 2011/06/23 15:28:42 hwoarang Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="World timezone definitions for Python"
+HOMEPAGE="http://pypi.python.org/pypi/pytz http://pytz.sourceforge.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ~ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ >=sys-libs/timezone-data-${PV}"
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGES.txt"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Use timezone-data zoneinfo.
+ epatch "${FILESDIR}/${PN}-2009j-zoneinfo.patch"
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" pytz/tests/test_tzinfo.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_zoneinfo() {
+ rm -fr "${ED}$(python_get_sitedir)/pytz/zoneinfo"
+ }
+ python_execute_function -q delete_zoneinfo
+}