summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-25 17:10:20 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-25 17:10:20 +0000
commit6f766613e81612cd4ada67f9073c4616e9278943 (patch)
tree1eee4d0e7ea28caf1a581db6c1f3d0116d682237 /dev-python/pyx/pyx-0.10-r1.ebuild
parentInitial commit. (diff)
downloadgentoo-2-6f766613e81612cd4ada67f9073c4616e9278943.tar.gz
gentoo-2-6f766613e81612cd4ada67f9073c4616e9278943.tar.bz2
gentoo-2-6f766613e81612cd4ada67f9073c4616e9278943.zip
Fix dependencies. Set SUPPORT_PYTHON_ABIS.
(Portage version: 2.2.0_alpha10_p8/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyx/pyx-0.10-r1.ebuild')
-rw-r--r--dev-python/pyx/pyx-0.10-r1.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/dev-python/pyx/pyx-0.10-r1.ebuild b/dev-python/pyx/pyx-0.10-r1.ebuild
index 8c5d2084cbfc..c195b4faf1e2 100644
--- a/dev-python/pyx/pyx-0.10-r1.ebuild
+++ b/dev-python/pyx/pyx-0.10-r1.ebuild
@@ -1,10 +1,16 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/pyx-0.10-r1.ebuild,v 1.1 2008/09/03 10:58:40 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/pyx-0.10-r1.ebuild,v 1.2 2010/12/25 17:10:20 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils eutils
-MY_P=${P/pyx/PyX}
+MY_P="${P/pyx/PyX}"
+
DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
HOMEPAGE="http://pyx.sourceforge.net/"
SRC_URI="mirror://sourceforge/pyx/${MY_P}.tar.gz"
@@ -14,18 +20,16 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
IUSE="doc"
-DEPEND="virtual/python
- virtual/tex-base
+RDEPEND="virtual/tex-base"
+DEPEND="${RDEPEND}
doc? ( virtual/latex-base )"
-RDEPEND="virtual/python
- virtual/tex-base"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
DOCS="AUTHORS CHANGES INSTALL"
-src_unpack() {
- distutils_src_unpack
+src_prepare() {
+ distutils_src_prepare
epatch "${FILESDIR}"/${P}.patch
sed -i \