summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-03-26 07:45:51 +0000
committerIan Delaney <idella4@gentoo.org>2014-03-26 07:45:51 +0000
commit573e0081921a40b3171c86dc0d0c23bd7b8f98d0 (patch)
tree1a1e6bc0fc4ba9c7ccbdff02489c768d663055e7 /dev-python/pyxdg/pyxdg-0.25-r1.ebuild
parentNeeds sys-libs/libstdc++-v3[multilib] (noticed after change due bug #435094) (diff)
downloadgentoo-2-573e0081921a40b3171c86dc0d0c23bd7b8f98d0.tar.gz
gentoo-2-573e0081921a40b3171c86dc0d0c23bd7b8f98d0.tar.bz2
gentoo-2-573e0081921a40b3171c86dc0d0c23bd7b8f98d0.zip
add sec patch wrt Bug #498934, rm old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyxdg/pyxdg-0.25-r1.ebuild')
-rw-r--r--dev-python/pyxdg/pyxdg-0.25-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pyxdg/pyxdg-0.25-r1.ebuild b/dev-python/pyxdg/pyxdg-0.25-r1.ebuild
new file mode 100644
index 000000000000..776108144007
--- /dev/null
+++ b/dev-python/pyxdg/pyxdg-0.25-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxdg/pyxdg-0.25-r1.ebuild,v 1.1 2014/03/26 07:45:51 idella4 Exp $
+
+EAPI=5
+
+# py3.3 removed due to nosetests
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+inherit distutils-r1
+
+DESCRIPTION="A Python module to deal with freedesktop.org specifications"
+HOMEPAGE="http://freedesktop.org/wiki/Software/pyxdg http://cgit.freedesktop.org/xdg/pyxdg/"
+SRC_URI="http://people.freedesktop.org/~takluyver/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}]
+ x11-themes/hicolor-icon-theme )"
+
+DOCS=( AUTHORS ChangeLog README TODO )
+PATCHES=( "${FILESDIR}"/sec-patch-CVE-2014-1624.patch )
+python_test() {
+ nosetests || die
+}