summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-11-30 23:35:29 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-11-30 23:35:29 +0000
commitf8af302dce2abaa1b2e4b44a512ff05b06bf0478 (patch)
treec89bc33acb8dc39cb79af1ebe96ce2bdd8d93bcc /dev-python/pyxml
parentnew release (Manifest recommit) (diff)
downloadgentoo-2-f8af302dce2abaa1b2e4b44a512ff05b06bf0478.tar.gz
gentoo-2-f8af302dce2abaa1b2e4b44a512ff05b06bf0478.tar.bz2
gentoo-2-f8af302dce2abaa1b2e4b44a512ff05b06bf0478.zip
Version bump
Diffstat (limited to 'dev-python/pyxml')
-rw-r--r--dev-python/pyxml/ChangeLog7
-rw-r--r--dev-python/pyxml/Manifest4
-rw-r--r--dev-python/pyxml/files/digest-pyxml-0.8.41
-rw-r--r--dev-python/pyxml/pyxml-0.8.4.ebuild46
4 files changed, 56 insertions, 2 deletions
diff --git a/dev-python/pyxml/ChangeLog b/dev-python/pyxml/ChangeLog
index bc74b98a7f0e..f85ea5ccbdc1 100644
--- a/dev-python/pyxml/ChangeLog
+++ b/dev-python/pyxml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyxml
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxml/ChangeLog,v 1.16 2004/10/17 11:43:08 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxml/ChangeLog,v 1.17 2004/11/30 23:35:29 pythonhead Exp $
+
+*pyxml-0.8.4 (30 Nov 2004)
+
+ 30 Nov 2004; Rob Cakebread <pythonhead@gentoo.org> +pyxml-0.8.4.ebuild:
+ Version bump
17 Oct 2004; Dylan Carlson <absinthe@gentoo.org> pyxml-0.8.3.ebuild:
stable on amd64.
diff --git a/dev-python/pyxml/Manifest b/dev-python/pyxml/Manifest
index 420d038e1eda..cdd8fc99ddea 100644
--- a/dev-python/pyxml/Manifest
+++ b/dev-python/pyxml/Manifest
@@ -1,10 +1,12 @@
-MD5 910b5f4acd08041100bde38f77fb58af ChangeLog 3525
+MD5 d46d8b2905f04c176575a1ad359348bb ChangeLog 3643
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
MD5 42a89c5ba45396e62ab002c6bce22509 pyxml-0.8.1.ebuild 641
MD5 e01536ad7dd2546c92112fb7e0d17420 pyxml-0.8.2.ebuild 915
MD5 8df7086d0618f8bfa7c49ba987fa542e pyxml-0.8.3.ebuild 928
MD5 150ddf2916b68c4fc68f1ff2c540296b pyxml-0.8.3-r1.ebuild 1135
+MD5 1c31c93cb68d32ac870b0287728d53e5 pyxml-0.8.4.ebuild 1035
MD5 b83e36b4dc90c3ce5840f0d2e432b7b2 files/digest-pyxml-0.8.1 63
MD5 6a14eefbf90c139b1f9b058131cb211f files/digest-pyxml-0.8.2 63
MD5 7d09f52601eefbf60eb70af6516bd302 files/digest-pyxml-0.8.3 63
MD5 7d09f52601eefbf60eb70af6516bd302 files/digest-pyxml-0.8.3-r1 63
+MD5 8d74fb8f5666f5ca295d21908b4912b0 files/digest-pyxml-0.8.4 63
diff --git a/dev-python/pyxml/files/digest-pyxml-0.8.4 b/dev-python/pyxml/files/digest-pyxml-0.8.4
new file mode 100644
index 000000000000..cda92bd054e1
--- /dev/null
+++ b/dev-python/pyxml/files/digest-pyxml-0.8.4
@@ -0,0 +1 @@
+MD5 1f7655050cebbb664db976405fdba209 PyXML-0.8.4.tar.gz 734954
diff --git a/dev-python/pyxml/pyxml-0.8.4.ebuild b/dev-python/pyxml/pyxml-0.8.4.ebuild
new file mode 100644
index 000000000000..218ea58ebd9d
--- /dev/null
+++ b/dev-python/pyxml/pyxml-0.8.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxml/pyxml-0.8.4.ebuild,v 1.1 2004/11/30 23:35:29 pythonhead Exp $
+
+inherit python distutils
+
+MY_P=${P/pyxml/PyXML}
+
+DESCRIPTION="A collection of libraries to process XML with Python"
+HOMEPAGE="http://pyxml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pyxml/${MY_P}.tar.gz"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/python
+ >=dev-libs/expat-1.95.6"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="ANNOUNCE CREDITS PKG-INFO TODO doc/*.txt"
+
+src_compile() {
+ local myconf
+
+ # if you want to use 4Suite, then their XSLT/XPATH is
+ # better according to the docs
+ if has_version "dev-python/4suite"; then
+ myconf="--without-xslt --without-xpath"
+ fi
+
+ distutils_src_compile ${myconf}
+}
+
+src_install() {
+ distutils_src_install
+
+ doman doc/man/*
+ dohtml -A api,web -r doc/*
+ insinto /usr/share/doc/${PF} && doins doc/*.tex
+ cp -r demo ${D}/usr/share/doc/${PF}
+ dodir /usr/share/${PN} && cp -r test ${D}/usr/share/${PN}
+}
+