summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-12-10 12:27:55 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-12-10 12:27:55 +0000
commit72e865b1007c3309cb13abd8e4449ac15d227d16 (patch)
tree6cc3f2b67618ce7383af34d4cf48aecfc0fef295 /dev-python/qscintilla-python/qscintilla-python-2.5.1.ebuild
parentVersion bump, remove old. (diff)
downloadgentoo-2-72e865b1007c3309cb13abd8e4449ac15d227d16.tar.gz
gentoo-2-72e865b1007c3309cb13abd8e4449ac15d227d16.tar.bz2
gentoo-2-72e865b1007c3309cb13abd8e4449ac15d227d16.zip
Version bump, remove old.
(Portage version: 2.2.0_alpha147/cvs/Linux x86_64, signed Manifest commit with key 17A85C72)
Diffstat (limited to 'dev-python/qscintilla-python/qscintilla-python-2.5.1.ebuild')
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.5.1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.5.1.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.5.1.ebuild
deleted file mode 100644
index 84bd15c02f66..000000000000
--- a/dev-python/qscintilla-python/qscintilla-python-2.5.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.5.1.ebuild,v 1.6 2012/03/25 17:59:08 pesa Exp $
-
-EAPI="3"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
-
-inherit eutils python toolchain-funcs
-
-MY_P="QScintilla-gpl-${PV/_pre/-snapshot-}"
-
-DESCRIPTION="Python bindings for Qscintilla"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
-SRC_URI="http://www.riverbankcomputing.co.uk/static/Downloads/QScintilla2/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 ~sparc x86"
-IUSE="debug"
-
-DEPEND=">=dev-python/sip-4.10
- >=dev-python/PyQt4-4.7[X]
- ~x11-libs/qscintilla-${PV}"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}/Python"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-disable_stripping.patch"
-
- python_copy_sources
-}
-
-src_configure() {
- configuration() {
- local myconf=("$(PYTHON)"
- configure.py
- -p 4
- --destdir="${EPREFIX}$(python_get_sitedir)/PyQt4"
- $(use debug && echo --debug))
- echo "${myconf[@]}"
- "${myconf[@]}"
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- building() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)"
- }
- python_execute_function -s building
-}