summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-06-27 13:42:26 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-06-27 13:42:26 +0000
commit7b86e0d2751a763423903be45087874733acd3c5 (patch)
treecba59ee5e90af10a8050c3b07ce2212de04271e4 /dev-python/qscintilla-python/qscintilla-python-2.6.2.ebuild
parentVersion bump and remove old. (diff)
downloadgentoo-2-7b86e0d2751a763423903be45087874733acd3c5.tar.gz
gentoo-2-7b86e0d2751a763423903be45087874733acd3c5.tar.bz2
gentoo-2-7b86e0d2751a763423903be45087874733acd3c5.zip
Version bump and remove old.
(Portage version: 2.2.0_alpha113/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/qscintilla-python/qscintilla-python-2.6.2.ebuild')
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.6.2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.6.2.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.6.2.ebuild
new file mode 100644
index 000000000000..5214eba3adfc
--- /dev/null
+++ b/dev-python/qscintilla-python/qscintilla-python-2.6.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.6.2.ebuild,v 1.1 2012/06/27 13:42:26 pesa Exp $
+
+EAPI=4
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython *-pypy-*"
+
+inherit eutils python toolchain-funcs
+
+MY_P=QScintilla-gpl-${PV}
+
+DESCRIPTION="Python bindings for Qscintilla"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
+SRC_URI="http://www.riverbankcomputing.co.uk/static/Downloads/QScintilla2/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND="
+ >=dev-python/sip-4.12
+ >=dev-python/PyQt4-4.8[X]
+ ~x11-libs/qscintilla-${PV}
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}/Python
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.5.1-disable_stripping.patch"
+
+ python_src_prepare
+}
+
+src_configure() {
+ configuration() {
+ local myconf=(
+ "$(PYTHON)"
+ configure.py
+ -p 4
+ --destdir="${EPREFIX}$(python_get_sitedir)/PyQt4"
+ $(use debug && echo --debug)
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}"
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ building() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)"
+ }
+ python_execute_function -s building
+}