summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-26 19:28:00 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-26 19:28:00 +0000
commit8535becd08caf02ec31a795ee36bc569252c448d (patch)
tree7504b392ba92608a64233d793b3976352781048c /dev-python/qscintilla-python
parentVersion bump. (diff)
downloadgentoo-2-8535becd08caf02ec31a795ee36bc569252c448d.tar.gz
gentoo-2-8535becd08caf02ec31a795ee36bc569252c448d.tar.bz2
gentoo-2-8535becd08caf02ec31a795ee36bc569252c448d.zip
Version bump.
(Portage version: 2.2.0_alpha30_p2/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/qscintilla-python')
-rw-r--r--dev-python/qscintilla-python/ChangeLog9
-rw-r--r--dev-python/qscintilla-python/files/qscintilla-python-2.5.1-disable_stripping.patch22
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.5.1.ebuild54
3 files changed, 84 insertions, 1 deletions
diff --git a/dev-python/qscintilla-python/ChangeLog b/dev-python/qscintilla-python/ChangeLog
index a502d02817d1..a8e97e06a0f7 100644
--- a/dev-python/qscintilla-python/ChangeLog
+++ b/dev-python/qscintilla-python/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/qscintilla-python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.74 2011/03/16 21:10:58 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.75 2011/04/26 19:28:00 arfrever Exp $
+
+*qscintilla-python-2.5.1 (26 Apr 2011)
+
+ 26 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +qscintilla-python-2.5.1.ebuild,
+ +files/qscintilla-python-2.5.1-disable_stripping.patch:
+ Version bump.
16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org>
qscintilla-python-2.4.5.ebuild:
diff --git a/dev-python/qscintilla-python/files/qscintilla-python-2.5.1-disable_stripping.patch b/dev-python/qscintilla-python/files/qscintilla-python-2.5.1-disable_stripping.patch
new file mode 100644
index 000000000000..50e1f91985a5
--- /dev/null
+++ b/dev-python/qscintilla-python/files/qscintilla-python-2.5.1-disable_stripping.patch
@@ -0,0 +1,22 @@
+--- Python/configure.py
++++ Python/configure.py
+@@ -312,7 +312,8 @@
+ universal=pyqt.universal,
+ arch=pyqt.arch,
+ prot_is_public=opts.prot_is_public,
+- deployment_target=pyqt.deployment_target
++ deployment_target=pyqt.deployment_target,
++ strip=0
+ )
+ else:
+ makefile = Makefile(
+@@ -321,7 +322,8 @@
+ install_dir=opts.qscimoddir,
+ installs=installs,
+ static=opts.static,
+- debug=opts.debug
++ debug=opts.debug,
++ strip=0
+ )
+
+ if qsci_define:
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.5.1.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.5.1.ebuild
new file mode 100644
index 000000000000..d507c9d393e3
--- /dev/null
+++ b/dev-python/qscintilla-python/qscintilla-python-2.5.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.5.1.ebuild,v 1.1 2011/04/26 19:28:00 arfrever Exp $
+
+EAPI="3"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit eutils python toolchain-funcs
+
+MY_P="QScintilla-gpl-${PV/_pre/-snapshot-}"
+
+DESCRIPTION="Python bindings for Qscintilla"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
+SRC_URI="http://www.riverbankcomputing.co.uk/static/Downloads/QScintilla2/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND=">=dev-python/sip-4.10
+ >=dev-python/PyQt4-4.7[X]
+ ~x11-libs/qscintilla-${PV}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/Python"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-disable_stripping.patch"
+
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ local myconf=("$(PYTHON)"
+ configure.py
+ -p 4
+ --destdir="${EPREFIX}$(python_get_sitedir)/PyQt4"
+ $(use debug && echo --debug))
+ echo "${myconf[@]}"
+ "${myconf[@]}"
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ building() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)"
+ }
+ python_execute_function -s building
+}