summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-22 06:29:56 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-22 06:29:56 +0000
commitbbad5f091a796076cd0f84847cb7b96e39f9d90b (patch)
tree18c24d31b813a1e0c94a27801f0aabad4ce65fd7 /dev-python/qscintilla-python
parentamd64 stable, bug #270950 (diff)
downloadgentoo-2-bbad5f091a796076cd0f84847cb7b96e39f9d90b.tar.gz
gentoo-2-bbad5f091a796076cd0f84847cb7b96e39f9d90b.tar.bz2
gentoo-2-bbad5f091a796076cd0f84847cb7b96e39f9d90b.zip
Respect CC, CXX (bug #275018).
(Portage version: 13659-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/qscintilla-python')
-rw-r--r--dev-python/qscintilla-python/ChangeLog6
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.4.ebuild12
2 files changed, 13 insertions, 5 deletions
diff --git a/dev-python/qscintilla-python/ChangeLog b/dev-python/qscintilla-python/ChangeLog
index f5e1318e1e3c..b9c2df9e221c 100644
--- a/dev-python/qscintilla-python/ChangeLog
+++ b/dev-python/qscintilla-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/qscintilla-python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.29 2009/06/19 20:35:55 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.30 2009/06/22 06:29:56 arfrever Exp $
+
+ 22 Jun 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ qscintilla-python-2.4.ebuild:
+ Respect CC, CXX (bug #275018).
19 Jun 2009; Brent Baude <ranger@gentoo.org>
qscintilla-python-2.3.2-r2.ebuild:
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild
index eee5996bfd71..37661f9a3de1 100644
--- a/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild
+++ b/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild,v 1.1 2009/06/09 19:03:20 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild,v 1.2 2009/06/22 06:29:56 arfrever Exp $
EAPI="2"
-inherit eutils multilib python
+inherit eutils multilib python toolchain-funcs
MY_P="QScintilla-gpl-${PV/_pre/-snapshot-}"
@@ -23,10 +23,10 @@ DEPEND=">=dev-python/sip-4.8
!qt4? ( >=dev-python/PyQt-3.18 )"
RDEPEND="${DEPEND}"
-S="${WORKDIR}"/${MY_P}/Python
+S="${WORKDIR}/${MY_P}/Python"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.4-nostrip.patch
+ epatch "${FILESDIR}/${PN}-2.4-nostrip.patch"
}
src_configure() {
@@ -42,6 +42,10 @@ src_configure() {
${myconf} || die "configuration failed"
}
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" || die "emake failed"
+}
+
src_install() {
python_need_rebuild
emake DESTDIR="${D}" install || die "emake install failed"