summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-19 10:11:21 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-19 10:11:21 +0000
commitdb7c5a5fbd909bd8b9eb71d58919a9b05b4de378 (patch)
tree2bfd665318cc1e977fbf536247d54c6a7824ebd9 /dev-python/reportlab
parentStable for amd64 wrt bug #508216 (diff)
downloadgentoo-2-db7c5a5fbd909bd8b9eb71d58919a9b05b4de378.tar.gz
gentoo-2-db7c5a5fbd909bd8b9eb71d58919a9b05b4de378.tar.bz2
gentoo-2-db7c5a5fbd909bd8b9eb71d58919a9b05b4de378.zip
add py3.4 support, tidy
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/reportlab')
-rw-r--r--dev-python/reportlab/ChangeLog5
-rw-r--r--dev-python/reportlab/reportlab-3.0.ebuild12
2 files changed, 11 insertions, 6 deletions
diff --git a/dev-python/reportlab/ChangeLog b/dev-python/reportlab/ChangeLog
index 18a71e849bf2..f9b22ddaac3d 100644
--- a/dev-python/reportlab/ChangeLog
+++ b/dev-python/reportlab/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/reportlab
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/ChangeLog,v 1.103 2014/04/17 05:37:36 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/ChangeLog,v 1.104 2014/05/19 10:11:21 idella4 Exp $
+
+ 19 May 2014; Ian Delaney <idella4@gentoo.org> reportlab-3.0.ebuild:
+ add py3.4 support, tidy
*reportlab-3.0 (17 Apr 2014)
diff --git a/dev-python/reportlab/reportlab-3.0.ebuild b/dev-python/reportlab/reportlab-3.0.ebuild
index 9b612d4748f6..7b6bbb0ff883 100644
--- a/dev-python/reportlab/reportlab-3.0.ebuild
+++ b/dev-python/reportlab/reportlab-3.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/reportlab-3.0.ebuild,v 1.1 2014/04/17 05:37:36 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/reportlab-3.0.ebuild,v 1.2 2014/05/19 10:11:21 idella4 Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
# Tests crash with pypy
inherit distutils-r1 flag-o-matic prefix
@@ -49,9 +49,11 @@ python_compile_all() {
use doc && emake -C docs html
}
-src_compile() {
- append-cflags -fno-strict-aliasing
- distutils-r1_src_compile
+python_compile() {
+ if ! python_is_python3; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ distutils-r1_python_compile
}
python_test() {