summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-31 19:11:06 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-31 19:11:06 +0000
commit63238b6d14e3ca2f9adcd229132e5c3f13e86aa5 (patch)
tree2963da0f78abe88a02bfbf28cdf2843950b89f45 /dev-python/rhpl/rhpl-0.219.ebuild
parentMarked ppc stable for bug #299867. (diff)
downloadgentoo-2-63238b6d14e3ca2f9adcd229132e5c3f13e86aa5.tar.gz
gentoo-2-63238b6d14e3ca2f9adcd229132e5c3f13e86aa5.tar.bz2
gentoo-2-63238b6d14e3ca2f9adcd229132e5c3f13e86aa5.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/rhpl/rhpl-0.219.ebuild')
-rw-r--r--dev-python/rhpl/rhpl-0.219.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/rhpl/rhpl-0.219.ebuild b/dev-python/rhpl/rhpl-0.219.ebuild
new file mode 100644
index 000000000000..b21be92e3816
--- /dev/null
+++ b/dev-python/rhpl/rhpl-0.219.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpl/rhpl-0.219.ebuild,v 1.1 2010/05/31 19:11:06 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit multilib python rpm toolchain-funcs
+
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="2"
+
+DESCRIPTION="Library of python code used by Red Hat Linux programs"
+HOMEPAGE="http://fedoraproject.org/wiki/SystemConfig"
+SRC_URI="mirror://fedora-dev/development/source/SRPMS/${P}-${RPMREV}.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!<sys-libs/libkudzu-1.2"
+DEPEND="${RDEPEND}
+ !s390? ( >=net-wireless/wireless-tools-28 )
+ sys-devel/gettext"
+
+src_prepare() {
+ sed -e '/compileall/d' -i Makefile || die "sed failed"
+ sed \
+ -e 's:CFLAGS=:CFLAGS+=:' \
+ -e 's:gcc:$(CC):g' \
+ -e 's:-shared:& $(LDFLAGS):' \
+ -i src/Makefile || die "sed failed"
+ python_src_prepare
+}
+
+src_compile() {
+ building() {
+ emake \
+ PYTHON=$(PYTHON) \
+ LIBDIR=$(get_libdir) \
+ ARCH=${ARCH} \
+ CC=$(tc-getCC)
+ }
+ python_execute_function -s building
+}
+
+src_install() {
+ installation() {
+ emake \
+ DESTDIR="${ED}" \
+ PYTHON=$(PYTHON) \
+ LIBDIR=$(get_libdir) \
+ install
+ }
+ python_execute_function -s installation
+}
+
+pkg_postinst() {
+ python_mod_optimize rhpl
+}
+
+pkg_postrm() {
+ python_mod_cleanup rhpl
+}