summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-04 21:32:45 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-04 21:32:45 +0000
commit092083e44272b38edd1d64e549dbc39b4bd09967 (patch)
tree98d0bfba3f0f017271382f0d8540b119d96c2065 /dev-python/rope
parentDelete older ebuilds. (diff)
downloadgentoo-2-092083e44272b38edd1d64e549dbc39b4bd09967.tar.gz
gentoo-2-092083e44272b38edd1d64e549dbc39b4bd09967.tar.bz2
gentoo-2-092083e44272b38edd1d64e549dbc39b4bd09967.zip
Version bump.
(Portage version: 15321-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/ChangeLog10
-rw-r--r--dev-python/rope/rope-0.9.3.ebuild35
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-python/rope/ChangeLog b/dev-python/rope/ChangeLog
index 8cc74f170d1f..be5b7cf1eccc 100644
--- a/dev-python/rope/ChangeLog
+++ b/dev-python/rope/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/rope
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rope/ChangeLog,v 1.5 2009/09/05 16:59:42 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rope/ChangeLog,v 1.6 2010/02/04 21:32:45 arfrever Exp $
+
+*rope-0.9.3 (04 Feb 2010)
+
+ 04 Feb 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +rope-0.9.3.ebuild:
+ Version bump.
05 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
rope-0.9.2.ebuild:
diff --git a/dev-python/rope/rope-0.9.3.ebuild b/dev-python/rope/rope-0.9.3.ebuild
new file mode 100644
index 000000000000..7667d064adce
--- /dev/null
+++ b/dev-python/rope/rope-0.9.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rope/rope-0.9.3.ebuild,v 1.1 2010/02/04 21:32:45 arfrever Exp $
+
+EAPI="2"
+NEED_PYTHON="2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="http://rope.sourceforge.net/ http://pypi.python.org/pypi/rope"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib:." "$(PYTHON)" ropetest/__init__.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ docinto docs
+ dodoc docs/*.txt
+}