summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2008-09-02 22:17:37 +0000
committerRob Cakebread <pythonhead@gentoo.org>2008-09-02 22:17:37 +0000
commit828cf51e7a24ea7e33e99771bb54ae0b19115aad (patch)
treec07c417e3cddea9f4e2a61f40a5ec321b496e031 /dev-python/ropeide/ropeide-1.5.1.ebuild
parentAdd doc USE flag. (diff)
downloadgentoo-2-828cf51e7a24ea7e33e99771bb54ae0b19115aad.tar.gz
gentoo-2-828cf51e7a24ea7e33e99771bb54ae0b19115aad.tar.bz2
gentoo-2-828cf51e7a24ea7e33e99771bb54ae0b19115aad.zip
Initial commit. Bug #202700. Thanks Matsui Tetsushi <VED03370@nifty.ne.jp> for the ebuild.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'dev-python/ropeide/ropeide-1.5.1.ebuild')
-rw-r--r--dev-python/ropeide/ropeide-1.5.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/ropeide/ropeide-1.5.1.ebuild b/dev-python/ropeide/ropeide-1.5.1.ebuild
new file mode 100644
index 000000000000..0680093d06e4
--- /dev/null
+++ b/dev-python/ropeide/ropeide-1.5.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ropeide/ropeide-1.5.1.ebuild,v 1.1 2008/09/02 22:17:37 pythonhead Exp $
+
+NEED_PYTHON="2.5"
+
+inherit distutils
+
+DESCRIPTION="Python refactoring IDE"
+HOMEPAGE="http://rope.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rope/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+DEPEND=">=dev-python/rope-0.8.4"
+
+pkg_setup() {
+ distutils_python_tkinter
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dodoc docs/*.txt
+}
+
+src_test() {
+ #Tests require a running X server and test module from dev-python/rope
+ #which isn't installed.
+ true
+}