summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-01 04:13:16 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-01 04:13:16 +0000
commit870368259df4b275060ffa7cfdb26a8134492b9a (patch)
tree2b8841037f0bb06bf65afba5f1ae24f49634d4b5 /dev-python/ropeide
parentUse PYTHON_DEPEND instead of NEED_PYTHON. Simplify src_test(). (diff)
downloadgentoo-2-870368259df4b275060ffa7cfdb26a8134492b9a.tar.gz
gentoo-2-870368259df4b275060ffa7cfdb26a8134492b9a.tar.bz2
gentoo-2-870368259df4b275060ffa7cfdb26a8134492b9a.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/ropeide')
-rw-r--r--dev-python/ropeide/ChangeLog6
-rw-r--r--dev-python/ropeide/ropeide-1.5.1-r1.ebuild22
2 files changed, 20 insertions, 8 deletions
diff --git a/dev-python/ropeide/ChangeLog b/dev-python/ropeide/ChangeLog
index 375add9185c0..6b10cf42d798 100644
--- a/dev-python/ropeide/ChangeLog
+++ b/dev-python/ropeide/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/ropeide
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ropeide/ChangeLog,v 1.3 2010/06/09 21:36:23 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ropeide/ChangeLog,v 1.4 2010/07/01 04:13:16 arfrever Exp $
+
+ 01 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ ropeide-1.5.1-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
09 Jun 2010; Patrick Lauer <patrick@gentoo.org> ropeide-1.5.1-r1.ebuild:
Adding ~amd64 keyword
diff --git a/dev-python/ropeide/ropeide-1.5.1-r1.ebuild b/dev-python/ropeide/ropeide-1.5.1-r1.ebuild
index 81e525ec48b5..5520a9cd043a 100644
--- a/dev-python/ropeide/ropeide-1.5.1-r1.ebuild
+++ b/dev-python/ropeide/ropeide-1.5.1-r1.ebuild
@@ -1,23 +1,31 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ropeide/ropeide-1.5.1-r1.ebuild,v 1.2 2010/06/09 21:36:23 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ropeide/ropeide-1.5.1-r1.ebuild,v 1.3 2010/07/01 04:13:16 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="tk"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
-NEED_PYTHON="2.5"
-EAPI=2
inherit distutils
DESCRIPTION="Python refactoring IDE"
-HOMEPAGE="http://rope.sourceforge.net/"
+HOMEPAGE="http://rope.sourceforge.net/ropeide.html http://pypi.python.org/pypi/ropeide"
SRC_URI="mirror://sourceforge/rope/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
-DEPEND=">=dev-python/rope-0.8.4
- >=dev-lang/python-2.5[tk]"
+DEPEND=">=dev-python/rope-0.8.4"
+RDEPEND="${DEPEND}"
src_install() {
distutils_src_install
- use doc && dodoc docs/*.txt
+
+ if use doc; then
+ dodoc docs/*.txt || die "dodoc failed"
+ fi
}