summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-26 09:49:27 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-26 09:49:27 +0000
commit231b7d8586c600492536ad4f02bc21e5bc7285f2 (patch)
tree08e01ac8d673b9aaedb7173adba9eb95211f91fd /dev-python/routes/routes-1.10.3.ebuild
parentInitial import. Dep of #260168, ebuild by PLL (diff)
downloadgentoo-2-231b7d8586c600492536ad4f02bc21e5bc7285f2.tar.gz
gentoo-2-231b7d8586c600492536ad4f02bc21e5bc7285f2.tar.bz2
gentoo-2-231b7d8586c600492536ad4f02bc21e5bc7285f2.zip
Bump to 1.10.3, dep for bug #260168
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/routes/routes-1.10.3.ebuild')
-rw-r--r--dev-python/routes/routes-1.10.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/routes/routes-1.10.3.ebuild b/dev-python/routes/routes-1.10.3.ebuild
new file mode 100644
index 000000000000..913692ce0f1a
--- /dev/null
+++ b/dev-python/routes/routes-1.10.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/routes-1.10.3.ebuild,v 1.1 2009/04/26 09:49:27 patrick Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+KEYWORDS="~amd64 ~x86"
+
+MY_PN=Routes
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A Python re-implementation of the Rails routes system for mapping URL's to Controllers/Actions."
+HOMEPAGE="http://routes.groovie.org"
+SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="doc? ( dev-python/buildutils dev-python/pudge )
+ dev-python/setuptools"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+ if use doc ; then
+ PYTHONPATH=. "${python}" setup.py pudge || die "generating docs failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r docs/html/*
+}