summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2008-10-10 18:54:01 +0000
committerRob Cakebread <pythonhead@gentoo.org>2008-10-10 18:54:01 +0000
commitcb994de0da1f33373a72137a86f0e3aec44154ce (patch)
treedc3caa3a50e5782ae18707224f080e366ad6c4fe /dev-python/setuptools
parentVersion bump. (diff)
downloadgentoo-2-cb994de0da1f33373a72137a86f0e3aec44154ce.tar.gz
gentoo-2-cb994de0da1f33373a72137a86f0e3aec44154ce.tar.bz2
gentoo-2-cb994de0da1f33373a72137a86f0e3aec44154ce.zip
Version bump.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/ChangeLog8
-rw-r--r--dev-python/setuptools/setuptools-0.6_rc9.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/setuptools/ChangeLog b/dev-python/setuptools/ChangeLog
index 99060d1588f9..2c8ccc03073f 100644
--- a/dev-python/setuptools/ChangeLog
+++ b/dev-python/setuptools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/setuptools
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.45 2008/07/18 17:48:31 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.46 2008/10/10 18:54:01 pythonhead Exp $
+
+*setuptools-0.6_rc9 (10 Oct 2008)
+
+ 10 Oct 2008; Rob Cakebread <pythonhead@gentoo.org>
+ +setuptools-0.6_rc9.ebuild:
+ Version bump.
18 Jul 2008; Santiago M. Mola <coldwind@gentoo.org>
setuptools-0.6_rc8-r1.ebuild:
diff --git a/dev-python/setuptools/setuptools-0.6_rc9.ebuild b/dev-python/setuptools/setuptools-0.6_rc9.ebuild
new file mode 100644
index 000000000000..6433dcb9244e
--- /dev/null
+++ b/dev-python/setuptools/setuptools-0.6_rc9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6_rc9.ebuild,v 1.1 2008/10/10 18:54:01 pythonhead Exp $
+
+NEED_PYTHON="2.4"
+
+inherit distutils eutils
+
+MY_P="${P/_rc/c}"
+
+DESCRIPTION="A collection of enhancements to the Python distutils including easy install"
+HOMEPAGE="http://peak.telecommunity.com/DevCenter/setuptools"
+SRC_URI="http://cheeseshop.python.org/packages/source/s/setuptools/${MY_P}.tar.gz"
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc
+~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="EasyInstall.txt api_tests.txt pkg_resources.txt setuptools.txt README.txt"
+
+src_unpack() {
+ distutils_src_unpack
+
+ epatch "${FILESDIR}/${PN}-0.6_rc7-noexe.patch"
+
+ # Remove tests that access the network (bugs #198312, #191117)
+ rm setuptools/tests/test_packageindex.py
+}
+
+src_test() {
+ PYTHONPATH="." "${python}" setup.py test || die "tests failed"
+}