summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-05 18:26:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-05 18:26:27 +0000
commitbae6662039d2c22fa641bd3e9efdcd6daa00fca3 (patch)
tree1c84c4a476219c64e5233eff5fa95ba874f13b78 /dev-python/sexy-python
parentVersion bump. (diff)
downloadgentoo-2-bae6662039d2c22fa641bd3e9efdcd6daa00fca3.tar.gz
gentoo-2-bae6662039d2c22fa641bd3e9efdcd6daa00fca3.tar.bz2
gentoo-2-bae6662039d2c22fa641bd3e9efdcd6daa00fca3.zip
Fix dependencies. Restrict Jython ABIs.
(Portage version: 2.2.0_alpha6_p21/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/sexy-python')
-rw-r--r--dev-python/sexy-python/ChangeLog6
-rw-r--r--dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild9
2 files changed, 10 insertions, 5 deletions
diff --git a/dev-python/sexy-python/ChangeLog b/dev-python/sexy-python/ChangeLog
index c20f57918910..1bed38669e89 100644
--- a/dev-python/sexy-python/ChangeLog
+++ b/dev-python/sexy-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/sexy-python
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sexy-python/ChangeLog,v 1.24 2010/10/18 13:50:06 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sexy-python/ChangeLog,v 1.25 2010/12/05 18:26:27 arfrever Exp $
+
+ 05 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ sexy-python-0.1.9-r1.ebuild:
+ Fix dependencies. Restrict Jython ABIs.
18 Oct 2010; Raúl Porcel <armin76@gentoo.org>
sexy-python-0.1.9-r1.ebuild:
diff --git a/dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild b/dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild
index 2398d1ace554..84ba1838c7a7 100644
--- a/dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild
+++ b/dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild,v 1.10 2010/10/18 13:50:06 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild,v 1.11 2010/12/05 18:26:27 arfrever Exp $
EAPI="3"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
inherit python
@@ -21,10 +23,9 @@ RDEPEND=">=x11-libs/libsexy-${PV}
>=dev-python/pygtk-2.6.2"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-RESTRICT_PYTHON_ABIS="3.*"
src_install() {
python_src_install
python_clean_installation_image
- dodoc AUTHORS ChangeLog NEWS README
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
}