summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-08-31 14:23:22 +0000
committerTim Harder <radhermit@gentoo.org>2014-08-31 14:23:22 +0000
commitca178ed3f130bee2f237a2b39832099303d65e93 (patch)
treef35b4e99f3018399e639518cd5baedfa684d5320 /dev-python/simplejson/simplejson-3.6.3-r1.ebuild
parentTyping error. (diff)
downloadgentoo-2-ca178ed3f130bee2f237a2b39832099303d65e93.tar.gz
gentoo-2-ca178ed3f130bee2f237a2b39832099303d65e93.tar.bz2
gentoo-2-ca178ed3f130bee2f237a2b39832099303d65e93.zip
Install CHANGES.txt documentation.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4F064CA3)
Diffstat (limited to 'dev-python/simplejson/simplejson-3.6.3-r1.ebuild')
-rw-r--r--dev-python/simplejson/simplejson-3.6.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/simplejson/simplejson-3.6.3-r1.ebuild b/dev-python/simplejson/simplejson-3.6.3-r1.ebuild
new file mode 100644
index 000000000000..09f30d1aa261
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.6.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.6.3-r1.ebuild,v 1.1 2014/08/31 14:23:22 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst CHANGES.txt )
+
+python_compile() {
+ if [[ ${EPYTHON} == python2.7 ]]; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}