summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2008-11-22 17:17:08 +0000
committerJesus Rivero <neurogeek@gentoo.org>2008-11-22 17:17:08 +0000
commit1d57e3b5aeb3eae20c44dc71f1a24756c83ed769 (patch)
tree1574ddd8a2fff2102f1c247aeaef54f373de525f /dev-python/simplejson
parentStable for HPPA (bug #245871). (diff)
downloadgentoo-2-1d57e3b5aeb3eae20c44dc71f1a24756c83ed769.tar.gz
gentoo-2-1d57e3b5aeb3eae20c44dc71f1a24756c83ed769.tar.bz2
gentoo-2-1d57e3b5aeb3eae20c44dc71f1a24756c83ed769.zip
Version bump
(Portage version: 2.2_rc12/cvs/Linux 2.6.18-gentoo-r3 i686)
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/ChangeLog7
-rw-r--r--dev-python/simplejson/simplejson-2.0.4.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index cfeda5d0fc48..5ac08a20cf10 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/simplejson
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.7 2008/01/04 17:23:34 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.8 2008/11/22 17:17:08 neurogeek Exp $
+
+*simplejson-2.0.4 (22 Nov 2008)
+
+ 22 Nov 2008; Jesus Rivero <neurogeek@gentoo.org> +simplejson-2.0.4.ebuild:
+ Version bump
*simplejson-1.7.3 (04 Jan 2008)
diff --git a/dev-python/simplejson/simplejson-2.0.4.ebuild b/dev-python/simplejson/simplejson-2.0.4.ebuild
new file mode 100644
index 000000000000..4f0a7099ac70
--- /dev/null
+++ b/dev-python/simplejson/simplejson-2.0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-2.0.4.ebuild,v 1.1 2008/11/22 17:17:08 neurogeek Exp $
+
+inherit distutils
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A simple, fast, complete, correct and extensible JSON encoder and decoder."
+HOMEPAGE="http://undefined.org/python/#simplejson"
+SRC_URI="http://cheeseshop.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="<dev-lang/python-2.6"
+DEPEND="dev-python/setuptools
+ ${RDEPEND}"
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/*
+ fi
+}
+
+src_test() {
+ PYTHONPATH=. "${python}" simplejson/tests/__init__.py || die "test failed"
+}