summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-17 18:21:48 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-17 18:21:48 +0000
commit3ede9bcb77fb1c55399e36ab72aa3fe6c44333a7 (patch)
tree8d31b95d51a12a77366a400614957327bfcf1df0 /dev-python/simplejson
parentintltool is always required (diff)
downloadgentoo-2-3ede9bcb77fb1c55399e36ab72aa3fe6c44333a7.tar.gz
gentoo-2-3ede9bcb77fb1c55399e36ab72aa3fe6c44333a7.tar.bz2
gentoo-2-3ede9bcb77fb1c55399e36ab72aa3fe6c44333a7.zip
Version bump.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/ChangeLog8
-rw-r--r--dev-python/simplejson/simplejson-2.1.5.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index 8a412e6747c2..6057f3ba30d8 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/simplejson
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.38 2011/03/11 14:36:10 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.39 2011/04/17 18:21:48 arfrever Exp $
+
+*simplejson-2.1.5 (17 Apr 2011)
+
+ 17 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +simplejson-2.1.5.ebuild:
+ Version bump.
11 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-simplejson-2.1.2.ebuild:
diff --git a/dev-python/simplejson/simplejson-2.1.5.ebuild b/dev-python/simplejson/simplejson-2.1.5.ebuild
new file mode 100644
index 000000000000..a5ce00c1a564
--- /dev/null
+++ b/dev-python/simplejson/simplejson-2.1.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-2.1.5.ebuild,v 1.1 2011/04/17 18:21:48 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+src_test() {
+ testing() {
+ if [[ "$(python_get_implementation)" != "Jython" ]]; then
+ ln -fs ../$(ls -d build-${PYTHON_ABI}/lib*)/simplejson/_speedups.so simplejson/_speedups.so || return 1
+ fi
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" simplejson/tests/__init__.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/simplejson/tests"
+ }
+ python_execute_function -q delete_tests
+}