summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2005-03-06 23:32:51 +0000
committerCarsten Lohrke <carlo@gentoo.org>2005-03-06 23:32:51 +0000
commit553bb4038443b2dd0f6bc66c007cfa1bc01f64b9 (patch)
treefbc778ae9442dc7c84e568dc2eee59843839f924 /dev-python/sip/sip-4.2.1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-553bb4038443b2dd0f6bc66c007cfa1bc01f64b9.tar.gz
gentoo-2-553bb4038443b2dd0f6bc66c007cfa1bc01f64b9.tar.bz2
gentoo-2-553bb4038443b2dd0f6bc66c007cfa1bc01f64b9.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-python/sip/sip-4.2.1.ebuild')
-rw-r--r--dev-python/sip/sip-4.2.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/sip/sip-4.2.1.ebuild b/dev-python/sip/sip-4.2.1.ebuild
new file mode 100644
index 000000000000..027175a9f820
--- /dev/null
+++ b/dev-python/sip/sip-4.2.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.2.1.ebuild,v 1.1 2005/03/06 23:31:03 carlo Exp $
+
+inherit distutils
+
+MY_P=${P/"?.?.?_pre"/"snapshot-"}
+MY_P=${MY_P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+#SRC_URI="http://www.river-bank.demon.co.uk/download/sip/${MY_P}.tar.gz"
+#SRC_URI="http://www.river-bank.demon.co.uk/download/snapshots/sip/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ppc64"
+IUSE="debug doc"
+
+DEPEND="virtual/libc
+ x11-libs/qt
+ >=dev-lang/python-2.3"
+
+src_compile(){
+ distutils_python_version
+
+ local myconf="-l qt-mt -b /usr/bin -d /usr/$(get_libdir)/python${PYVER}/site-packages -e /usr/include/python${PYVER}"
+ use debug && myconf="${myconf} -u"
+
+ python configure.py ${myconf} "CFLAGS+=${CFLAGS}" "CXXFLAGS+=${CXXFLAGS}"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc ChangeLog LICENSE NEWS README THANKS TODO
+ if use doc ; then dohtml doc/* ; fi
+}
+
+pkg_postinst() {
+ echo ""
+ einfo "Please note, that you have to emerge PyQt again, when upgrading from sip-3.x."
+ echo ""
+}