summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-05-28 00:06:56 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-05-28 00:06:56 +0000
commit08fd0cfa576bd7d2a71575065ec3bf84d6932ee9 (patch)
tree13742992f333ab968e2fc0871ed93220f6e08215 /dev-python/sip
parent27 May 2011; Zac Medico <zmedico@gentoo.org> -portage-2.2.0_alpha34.ebuild, (diff)
downloadgentoo-2-08fd0cfa576bd7d2a71575065ec3bf84d6932ee9.tar.gz
gentoo-2-08fd0cfa576bd7d2a71575065ec3bf84d6932ee9.tar.bz2
gentoo-2-08fd0cfa576bd7d2a71575065ec3bf84d6932ee9.zip
Version bump. remove old
(Portage version: 2.2.0_alpha36/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/ChangeLog8
-rw-r--r--dev-python/sip/sip-4.12.3.ebuild (renamed from dev-python/sip/sip-4.12.2.ebuild)2
-rw-r--r--dev-python/sip/sip-4.12.ebuild77
3 files changed, 8 insertions, 79 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index e3a8d065ae9a..09ed6a1aa51a 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.191 2011/05/09 23:01:33 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.192 2011/05/28 00:06:56 hwoarang Exp $
+
+*sip-4.12.3 (28 May 2011)
+
+ 28 May 2011; Markos Chandras <hwoarang@gentoo.org> -sip-4.12.ebuild,
+ -sip-4.12.2.ebuild, +sip-4.12.3.ebuild:
+ Version bump. remove old
09 May 2011; Markos Chandras <hwoarang@gentoo.org> sip-4.12.1.ebuild:
Stable on amd64 wrt bug #354033
diff --git a/dev-python/sip/sip-4.12.2.ebuild b/dev-python/sip/sip-4.12.3.ebuild
index e91215bbd6f4..e5711e6fea45 100644
--- a/dev-python/sip/sip-4.12.2.ebuild
+++ b/dev-python/sip/sip-4.12.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.12.2.ebuild,v 1.1 2011/05/02 17:55:56 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.12.3.ebuild,v 1.1 2011/05/28 00:06:56 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="*"
diff --git a/dev-python/sip/sip-4.12.ebuild b/dev-python/sip/sip-4.12.ebuild
deleted file mode 100644
index 8e695becb781..000000000000
--- a/dev-python/sip/sip-4.12.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.12.ebuild,v 1.1 2010/12/24 15:19:12 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
-
-inherit eutils python toolchain-funcs
-
-MY_P="${P/_pre/-snapshot-}"
-
-DESCRIPTION="Python extension module generator for C and C++ libraries"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 sip )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="debug doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-4.9.3-darwin.patch"
- python_copy_sources
-}
-
-src_configure() {
- configuration() {
- local myconf=("$(PYTHON)"
- configure.py
- --bindir="${EPREFIX}/usr/bin"
- --incdir="${EPREFIX}$(python_get_includedir)"
- --destdir="${EPREFIX}$(python_get_sitedir)"
- --sipdir="${EPREFIX}/usr/share/sip"
- $(use debug && echo --debug)
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- LINK="$(tc-getCXX)"
- LINK_SHLIB="$(tc-getCXX)"
- CFLAGS="${CFLAGS}"
- CXXFLAGS="${CXXFLAGS}"
- LFLAGS="${LDFLAGS}"
- STRIP=":")
- echo "${myconf[@]}"
- "${myconf[@]}"
- }
- python_execute_function -s configuration
-}
-
-src_install() {
- python_src_install
-
- dodoc NEWS || die "dodoc failed"
-
- if use doc; then
- dohtml -r doc/html/* || die "dohtml failed"
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize sipconfig.py sipdistutils.py
-
- ewarn "When updating dev-python/sip, you usually need to rebuild packages, which depend on dev-python/sip,"
- ewarn "such as dev-python/PyQt4 and dev-python/qscintilla-python. If you have app-portage/gentoolkit"
- ewarn "installed, you can find these packages with \`equery d dev-python/sip dev-python/PyQt4\`."
-}
-
-pkg_postrm() {
- python_mod_cleanup sipconfig.py sipdistutils.py
-}