summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-02-16 06:22:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-02-16 06:22:44 +0000
commit9e3af15a32590b2c30851c285f6c35c2e808af7e (patch)
tree07116e74cc42b358b5423e94648031eaa0a26727 /dev-python/snakeoil
parentDo not run install_config mmake rule (diff)
downloadgentoo-2-9e3af15a32590b2c30851c285f6c35c2e808af7e.tar.gz
gentoo-2-9e3af15a32590b2c30851c285f6c35c2e808af7e.tar.bz2
gentoo-2-9e3af15a32590b2c30851c285f6c35c2e808af7e.zip
non-maintainer version bump at upstream's request
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'dev-python/snakeoil')
-rw-r--r--dev-python/snakeoil/ChangeLog8
-rw-r--r--dev-python/snakeoil/snakeoil-0.3.6.2.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/snakeoil/ChangeLog b/dev-python/snakeoil/ChangeLog
index e6572d4364f6..d59a43e4ffe6 100644
--- a/dev-python/snakeoil/ChangeLog
+++ b/dev-python/snakeoil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/snakeoil
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/ChangeLog,v 1.29 2010/02/08 19:17:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/ChangeLog,v 1.30 2010/02/16 06:22:44 mr_bones_ Exp $
+
+*snakeoil-0.3.6.2 (16 Feb 2010)
+
+ 16 Feb 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +snakeoil-0.3.6.2.ebuild:
+ non-maintainer version bump at upstream's request
*snakeoil-0.3.6.1 (08 Feb 2010)
diff --git a/dev-python/snakeoil/snakeoil-0.3.6.2.ebuild b/dev-python/snakeoil/snakeoil-0.3.6.2.ebuild
new file mode 100644
index 000000000000..7e91d2713447
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.3.6.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/snakeoil-0.3.6.2.ebuild,v 1.1 2010/02/16 06:22:44 mr_bones_ Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Miscellaneous python utility code."
+HOMEPAGE="http://www.pkgcore.org/"
+SRC_URI="http://www.pkgcore.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="!<sys-apps/pkgcore-0.4.7.8"
+RDEPEND=${DEPEND}
+
+DOCS="AUTHORS NEWS"
+
+pkg_setup() {
+ validate_PYTHON_ABIS
+
+ # A hack to install for all versions of Python in the system.
+ # pkgcore needs it to support upgrading to a different Python slot.
+ PYTHON_ABIS=""
+ local python_interpreter
+ for python_interpreter in /usr/bin/python{2.[4-9],3.[1-9]}; do
+ if [[ -x "${python_interpreter}" ]]; then
+ PYTHON_ABIS+=" ${python_interpreter#/usr/bin/python}"
+ fi
+ done
+ export PYTHON_ABIS="${PYTHON_ABIS# }"
+}
+
+src_test() {
+ testing() {
+ local tempdir
+ tempdir="${T}/tests/python-${PYTHON_ABI}"
+ mkdir -p "${tempdir}" || die "tempdir creation failed"
+ cp -r "${S}" "${tempdir}" || die "test copy failed"
+ cd "${tempdir}/${P}"
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" test
+ }
+ python_execute_function testing
+}