summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2011-11-18 10:03:00 +0000
committerAndrey Grozin <grozin@gentoo.org>2011-11-18 10:03:00 +0000
commit5dc2fc9b087bbbc7437980edc62567ab70e9e60d (patch)
treee83defaae1caaa80c383413b029c9cbe8afdab03 /dev-python/spyder
parentAdd ~x86-fbsd (diff)
downloadgentoo-2-5dc2fc9b087bbbc7437980edc62567ab70e9e60d.tar.gz
gentoo-2-5dc2fc9b087bbbc7437980edc62567ab70e9e60d.tar.bz2
gentoo-2-5dc2fc9b087bbbc7437980edc62567ab70e9e60d.zip
Version bump (bug #390777), new USE flag pep8, cleaning old versions
(Portage version: 2.2.0_alpha74/cvs/Linux i686)
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/ChangeLog10
-rw-r--r--dev-python/spyder/files/spyder-2.0.4-disable_sphinx_dependency.patch54
-rw-r--r--dev-python/spyder/metadata.xml1
-rw-r--r--dev-python/spyder/spyder-2.0.11.ebuild57
-rw-r--r--dev-python/spyder/spyder-2.0.8.ebuild57
-rw-r--r--dev-python/spyder/spyder-2.1.2.ebuild (renamed from dev-python/spyder/spyder-2.0.10.ebuild)20
6 files changed, 19 insertions, 180 deletions
diff --git a/dev-python/spyder/ChangeLog b/dev-python/spyder/ChangeLog
index a91c193c9bf7..6778336fad6b 100644
--- a/dev-python/spyder/ChangeLog
+++ b/dev-python/spyder/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/spyder
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.20 2011/07/29 23:10:01 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.21 2011/11/18 10:02:59 grozin Exp $
+
+*spyder-2.1.2 (18 Nov 2011)
+
+ 18 Nov 2011; Andrey Grozin <grozin@gentoo.org>
+ -files/spyder-2.0.4-disable_sphinx_dependency.patch, -spyder-2.0.8.ebuild,
+ -spyder-2.0.10.ebuild, -spyder-2.0.11.ebuild, +spyder-2.1.2.ebuild,
+ metadata.xml:
+ Version bump (bug #390777), new USE flag pep8, cleaning old versions
29 Jul 2011; Sébastien Fabbro <bicatali@gentoo.org> spyder-2.0.12.ebuild:
Added desktop file and icon, bug #363409, thanks spiros
diff --git a/dev-python/spyder/files/spyder-2.0.4-disable_sphinx_dependency.patch b/dev-python/spyder/files/spyder-2.0.4-disable_sphinx_dependency.patch
deleted file mode 100644
index f87b405faa37..000000000000
--- a/dev-python/spyder/files/spyder-2.0.4-disable_sphinx_dependency.patch
+++ /dev/null
@@ -1,54 +0,0 @@
---- setup.py
-+++ setup.py
-@@ -13,7 +13,6 @@
-
- from distutils.core import setup
- from distutils.command.build import build
--from sphinx import setup_command
- import os, os.path as osp, sys
-
-
-@@ -36,27 +35,6 @@
- splist.append(".".join(dirpath.split(os.sep)))
- return splist
-
--# Sphinx build (documentation)
--class MyBuild(build):
-- def has_doc(self):
-- setup_dir = os.path.dirname(os.path.abspath(__file__))
-- return os.path.isdir(os.path.join(setup_dir, 'doc'))
-- sub_commands = build.sub_commands + [('build_doc', has_doc)]
--
--class MyBuildDoc(setup_command.BuildDoc):
-- def run(self):
-- build = self.get_finalized_command('build')
-- sys.path.insert(0, os.path.abspath(build.build_lib))
-- dirname = self.distribution.get_command_obj('build').build_purelib
-- self.builder_target_dir = osp.join(dirname, 'spyderlib', 'doc')
-- try:
-- setup_command.BuildDoc.run(self)
-- except UnicodeDecodeError:
-- print >>sys.stderr, "ERROR: unable to build documentation because Sphinx do not handle source path with non-ASCII characters. Please try to move the source package to another location (path with *only* ASCII characters)."
-- sys.path.pop(0)
--
--cmdclass = {'build': MyBuild, 'build_doc': MyBuildDoc}
--
-
- NAME = 'spyder'
- LIBNAME = 'spyderlib'
-@@ -83,7 +61,7 @@
- get_package_data(LIBNAME, ('.qm', '.svg', '.png', '.css')),
- 'spyderplugins':
- get_package_data('spyderplugins', ('.qm', '.svg', '.png'))},
-- requires=["pyflakes (>0.3.0)", "rope (>0.9.0)", "sphinx (>0.6.0)",
-+ requires=["pyflakes (>0.3.0)", "rope (>0.9.0)",
- "PyQt4 (>4.3)"],
- scripts=['spyder', 'spyder.bat'] if os.name == 'nt' else ['spyder'],
- classifiers=['License :: OSI Approved :: MIT License',
-@@ -97,5 +75,4 @@
- 'Programming Language :: Python :: 2.7',
- 'Development Status :: 5 - Production/Stable',
- 'Topic :: Scientific/Engineering',
-- 'Topic :: Software Development :: Widget Sets'],
-- cmdclass=cmdclass)
-+ 'Topic :: Software Development :: Widget Sets'])
diff --git a/dev-python/spyder/metadata.xml b/dev-python/spyder/metadata.xml
index f3e00bf96c12..334179b7f7b1 100644
--- a/dev-python/spyder/metadata.xml
+++ b/dev-python/spyder/metadata.xml
@@ -16,6 +16,7 @@
<flag name='ipython'>Add support for <pkg>dev-python/ipython</pkg></flag>
<flag name='matplotlib'>Add support for <pkg>dev-python/matplotlib</pkg></flag>
<flag name='numpy'>Add support for <pkg>dev-python/numpy</pkg></flag>
+ <flag name='pep8'>Add support for <pkg>dev-python/pep8</pkg></flag>
<flag name='pyflakes'>Add support for <pkg>dev-python/pyflakes</pkg></flag>
<flag name='pylint'>Add support for <pkg>dev-python/pylint</pkg></flag>
<flag name='rope'>Add support for <pkg>sci-libs/rope</pkg></flag>
diff --git a/dev-python/spyder/spyder-2.0.11.ebuild b/dev-python/spyder/spyder-2.0.11.ebuild
deleted file mode 100644
index 313baefb170e..000000000000
--- a/dev-python/spyder/spyder-2.0.11.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.0.11.ebuild,v 1.1 2011/04/29 21:24:42 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
-
-inherit distutils eutils
-
-DESCRIPTION="Python IDE with matlab-like features"
-HOMEPAGE="http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder"
-SRC_URI="http://spyderlib.googlecode.com/files/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc ipython matplotlib numpy +pyflakes pylint +rope scipy"
-
-RDEPEND=">=dev-python/PyQt4-4.4[webkit]
- ipython? ( dev-python/ipython )
- matplotlib? ( dev-python/matplotlib )
- numpy? ( dev-python/numpy )
- pyflakes? ( >=dev-python/pyflakes-0.3 )
- pylint? ( dev-python/pylint )
- rope? ( >=dev-python/rope-0.9.0 )
- scipy? ( sci-libs/scipy )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-
-PYTHON_MODNAME="spyderlib spyderplugins"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${PN}-2.0.10-disable_sphinx_dependency.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- PYTHONPATH="build-$(PYTHON -f --ABI)" sphinx-build doc doc_output || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- pushd doc_output > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _images _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-}
diff --git a/dev-python/spyder/spyder-2.0.8.ebuild b/dev-python/spyder/spyder-2.0.8.ebuild
deleted file mode 100644
index 76f6e005e6b7..000000000000
--- a/dev-python/spyder/spyder-2.0.8.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.0.8.ebuild,v 1.1 2011/03/01 16:43:20 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
-
-inherit distutils eutils
-
-DESCRIPTION="Python IDE with matlab-like features"
-HOMEPAGE="http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder"
-SRC_URI="http://spyderlib.googlecode.com/files/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc ipython matplotlib numpy +pyflakes pylint +rope scipy"
-
-RDEPEND=">=dev-python/PyQt4-4.4[webkit]
- ipython? ( dev-python/ipython )
- matplotlib? ( dev-python/matplotlib )
- numpy? ( dev-python/numpy )
- pyflakes? ( >=dev-python/pyflakes-0.3 )
- pylint? ( dev-python/pylint )
- rope? ( >=dev-python/rope-0.9.0 )
- scipy? ( sci-libs/scipy )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-
-PYTHON_MODNAME="spyderlib spyderplugins"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${PN}-2.0.4-disable_sphinx_dependency.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- PYTHONPATH="build-$(PYTHON -f --ABI)" sphinx-build doc doc_output || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- pushd doc_output > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _images _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-}
diff --git a/dev-python/spyder/spyder-2.0.10.ebuild b/dev-python/spyder/spyder-2.1.2.ebuild
index 8ae3653304ff..96dd7a3f601b 100644
--- a/dev-python/spyder/spyder-2.0.10.ebuild
+++ b/dev-python/spyder/spyder-2.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.0.10.ebuild,v 1.1 2011/04/06 14:26:36 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.1.2.ebuild,v 1.1 2011/11/18 10:02:59 grozin Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
@@ -16,7 +16,7 @@ SRC_URI="http://spyderlib.googlecode.com/files/${P}.zip"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc ipython matplotlib numpy +pyflakes pylint +rope scipy"
+IUSE="doc ipython matplotlib numpy +pyflakes pylint +rope scipy pep8"
RDEPEND=">=dev-python/PyQt4-4.4[webkit]
ipython? ( dev-python/ipython )
@@ -24,30 +24,28 @@ RDEPEND=">=dev-python/PyQt4-4.4[webkit]
numpy? ( dev-python/numpy )
pyflakes? ( >=dev-python/pyflakes-0.3 )
pylint? ( dev-python/pylint )
- rope? ( >=dev-python/rope-0.9.0 )
- scipy? ( sci-libs/scipy )"
+ rope? ( >=dev-python/rope-0.9.3 )
+ scipy? ( sci-libs/scipy )
+ pep8? ( dev-python/pep8 )"
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx )"
PYTHON_MODNAME="spyderlib spyderplugins"
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${P}-disable_sphinx_dependency.patch"
-}
-
src_compile() {
distutils_src_compile
if use doc; then
einfo "Generation of documentation"
- PYTHONPATH="build-$(PYTHON -f --ABI)" sphinx-build doc doc_output || die "Generation of documentation failed"
+ PYTHONPATH="build-$(PYTHON -f --ABI)" \
+ sphinx-build doc doc_output || die "Generation of documentation failed"
fi
}
src_install() {
distutils_src_install
-
+ doicon spyderlib/images/spyder.svg || die
+ make_desktop_entry spyder Spyder spyder "Development;IDE"
if use doc; then
pushd doc_output > /dev/null
insinto /usr/share/doc/${PF}/html