summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-23 20:41:01 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-23 20:41:01 +0000
commit9dec47d2e2fc4d882cd7cc27d29e70c8c21012bf (patch)
tree61f91e382736abe4121243dfa702eba7c828a32a /dev-python/spyder
parentDelete older ebuild. (diff)
downloadgentoo-2-9dec47d2e2fc4d882cd7cc27d29e70c8c21012bf.tar.gz
gentoo-2-9dec47d2e2fc4d882cd7cc27d29e70c8c21012bf.tar.bz2
gentoo-2-9dec47d2e2fc4d882cd7cc27d29e70c8c21012bf.zip
Version bump.
(Portage version: 2.2.0_alpha1_p3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/ChangeLog8
-rw-r--r--dev-python/spyder/spyder-1.1.8.ebuild29
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/spyder/ChangeLog b/dev-python/spyder/ChangeLog
index c3c09af8f4e0..97b27e27b7fc 100644
--- a/dev-python/spyder/ChangeLog
+++ b/dev-python/spyder/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/spyder
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.9 2010/09/23 21:17:35 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.10 2010/10/23 20:41:01 arfrever Exp $
+
+*spyder-1.1.8 (23 Oct 2010)
+
+ 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -spyder-1.1.3.ebuild, +spyder-1.1.8.ebuild:
+ Version bump.
*spyder-1.1.6 (23 Sep 2010)
diff --git a/dev-python/spyder/spyder-1.1.8.ebuild b/dev-python/spyder/spyder-1.1.8.ebuild
new file mode 100644
index 000000000000..4ac08e758def
--- /dev/null
+++ b/dev-python/spyder/spyder-1.1.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-1.1.8.ebuild,v 1.1 2010/10/23 20:41:01 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils
+
+DESCRIPTION="Python IDE with matlab-like features"
+HOMEPAGE="http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder"
+SRC_URI="http://spyderlib.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="matplotlib mayavi numpy pylint scipy"
+
+RDEPEND=">=dev-python/PyQt4-4.4[webkit]
+ >=dev-python/qscintilla-python-2.1
+ matplotlib? ( dev-python/matplotlib )
+ mayavi? ( sci-visualization/mayavi:2 )
+ numpy? ( dev-python/numpy )
+ pylint? ( dev-python/pylint )
+ scipy? ( sci-libs/scipy )"
+
+PYTHON_MODNAME="spyderlib spyderplugins"