summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-02-20 11:30:34 +0000
committerIan Delaney <idella4@gentoo.org>2015-02-20 11:30:34 +0000
commitb4aeccef386c9333b600b2c5848ff7468d7170bb (patch)
tree7b01968fcebd016dd7c3ec90bfbe0a52eb1270b4 /dev-python/storm
parentDrop old (diff)
downloadgentoo-2-b4aeccef386c9333b600b2c5848ff7468d7170bb.tar.gz
gentoo-2-b4aeccef386c9333b600b2c5848ff7468d7170bb.tar.bz2
gentoo-2-b4aeccef386c9333b600b2c5848ff7468d7170bb.zip
revbump; convert -> distutils-r1, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/storm')
-rw-r--r--dev-python/storm/ChangeLog8
-rw-r--r--dev-python/storm/storm-0.20-r1.ebuild65
-rw-r--r--dev-python/storm/storm-0.20.ebuild72
3 files changed, 72 insertions, 73 deletions
diff --git a/dev-python/storm/ChangeLog b/dev-python/storm/ChangeLog
index 9a69774ac986..aceb90641dc8 100644
--- a/dev-python/storm/ChangeLog
+++ b/dev-python/storm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/storm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/storm/ChangeLog,v 1.17 2015/01/23 05:06:04 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/storm/ChangeLog,v 1.18 2015/02/20 11:30:34 idella4 Exp $
+
+*storm-0.20-r1 (20 Feb 2015)
+
+ 20 Feb 2015; Ian Delaney <idella4@gentoo.org> +storm-0.20-r1.ebuild,
+ -storm-0.20.ebuild:
+ revbump; convert -> distutils-r1, rm old
23 Jan 2015; Manuel Rüger <mrueg@gentoo.org> -storm-0.18.ebuild,
-storm-0.19.ebuild:
diff --git a/dev-python/storm/storm-0.20-r1.ebuild b/dev-python/storm/storm-0.20-r1.ebuild
new file mode 100644
index 000000000000..9f05c02be4a9
--- /dev/null
+++ b/dev-python/storm/storm-0.20-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/storm/storm-0.20-r1.ebuild,v 1.1 2015/02/20 11:30:34 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_REQ_USE="sqlite?"
+
+inherit distutils-r1
+
+DESCRIPTION="An object-relational mapper for Python developed at Canonical"
+HOMEPAGE="https://storm.canonical.com/ http://pypi.python.org/pypi/storm"
+SRC_URI="http://launchpad.net/storm/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mysql postgres sqlite test"
+
+RDEPEND="mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ postgres? ( =dev-python/psycopg-2*[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/fixtures[${PYTHON_USEDEP}] )"
+
+CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+DOCS="tests/tutorial.txt"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+python_prepare_all() {
+ sed -e "s:find_packages():find_packages(exclude=['test','test.*']):" \
+ -i setup.py || die
+
+ # delete rogue errors in setting exceptions
+ sed -e '/module_exception is not None:/d' \
+ -e '/module_exception.__bases__ += (exception,)/d' \
+ -i storm/exceptions.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if use mysql; then
+ elog "To run the MySQL-tests, you need:"
+ elog " - a running mysql-server"
+ elog " - an already existing database 'db'"
+ elog " - a user 'user' with full permissions on that database"
+ elog " - and an environment variable STORM_MYSQL_URI=\"mysql://user:password@host:1234/db\""
+ fi
+ if use postgres; then
+ elog "To run the PostgreSQL-tests, you need:"
+ elog " - a running postgresql-server"
+ elog " - an already existing database 'db'"
+ elog " - a user 'user' with full permissions on that database"
+ elog " - and an environment variable STORM_POSTGRES_URI=\"postgres://user:password@host:1234/db\""
+ fi
+
+ # Some tests require a server instance which is absent
+ "${PYTHON}" test --verbose
+}
diff --git a/dev-python/storm/storm-0.20.ebuild b/dev-python/storm/storm-0.20.ebuild
deleted file mode 100644
index ba7b5581fec1..000000000000
--- a/dev-python/storm/storm-0.20.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/storm/storm-0.20.ebuild,v 1.4 2014/08/10 21:22:56 slyfox Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*-jython"
-
-inherit distutils eutils
-
-DESCRIPTION="An object-relational mapper for Python developed at Canonical"
-HOMEPAGE="https://storm.canonical.com/ http://pypi.python.org/pypi/storm"
-SRC_URI="http://launchpad.net/storm/trunk/${PV}/+download/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="mysql postgres sqlite test"
-
-RDEPEND="mysql? ( dev-python/mysql-python )
- postgres? ( =dev-python/psycopg-2* )
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
-DEPEND="dev-python/setuptools
- test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 )
- dev-python/fixtures )"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-DOCS="tests/tutorial.txt"
-
-src_prepare() {
- epatch "${FILESDIR}/storm-0.20-exclude-tests.patch"
-
- distutils_src_prepare
-
- preparation() {
- if [[ "$(python_get_implementation)" == "Jython" ]]; then
- sed -e "s/BUILD_CEXTENSIONS = True/BUILD_CEXTENSIONS = False/" -i setup.py
- fi
- }
- python_execute_function -s preparation
-}
-
-src_test() {
- if use mysql; then
- elog "To run the MySQL-tests, you need:"
- elog " - a running mysql-server"
- elog " - an already existing database 'db'"
- elog " - a user 'user' with full permissions on that database"
- elog " - and an environment variable STORM_MYSQL_URI=\"mysql://user:password@host:1234/db\""
- fi
- if use postgres; then
- elog "To run the PostgreSQL-tests, you need:"
- elog " - a running postgresql-server"
- elog " - an already existing database 'db'"
- elog " - a user 'user' with full permissions on that database"
- elog " - and an environment variable STORM_POSTGRES_URI=\"postgres://user:password@host:1234/db\""
- fi
-
- testing() {
- PYTHONPATH="$(ls -d build/lib*)" "$(PYTHON)" test --verbose
- }
- python_execute_function -s testing
-}
-
-src_install() {
- distutils_src_install
- python_clean_installation_image
-}